3. Organisation de Grace en graphes et courbes#

3.1. Généralités#

Pour Grace, un graphe est un graphique pouvant contenir plusieurs courbes, un “projet” Grace (pouvant être sauvegardé dans un fichier portant l’extension “agr) peut contenir plusieurs graphes.

Les graphes sont nommés G0, G1,…

Les courbes sont nommées S0, S1,…

3.2. Gestion des graphes#

L’utilisateur peut gérer les graphes dans chaque liste de sélection de graphes (par exemple dans les menus Edit/Arrange Graphs, Edit/Set Operations, Edit/Overlay Graphs, Plot/Graph Appearance comme sur l’illustration ci-dessous ou Data/Import/Ascii).

_images/10000201000001510000025CFF942988A33FE560.png

Dans la zone en dessous de “Graph”, on trouve une liste de graphes (ici, le projet comporte deux graphes, le premier comprenant trois courbe, le second comprenant une seule courbe). On notera le “(-)” devant le premier graphe, qui signifie que le premier graphe est “caché” (hidden, i.e. non affiché), tandis que le (+) devant le second signifie qu’il est affiché (showed). Le ou les graphes mis en surbrillance sont le ou les graphes concernés par l’action en cours : ici, la modification du graphe concerne G0 (même s’il est caché !). De même, à l’importation d’une courbe :

_images/100002010000018F000002D28BB5452CD0244208.png

la courbe que l’utilisateur se prépare à importer ira dans le graphe G0 (comme précédemment, ce graphe étant caché, la courbe importée ne s’affichera pas).

Dans certains menus (Plot/Graph Appearance par exemple), il est possible de sélectionner plusieurs graphes (de façon habituelle : Ctrl + clic gauche pour une sélection de graphe “un par un” ou Shift + clic gauche sur le premier et dernier élément d’une liste contigüe ou clic gauche + déplacement de la souris sur une liste….), tandis que d’autres menus (Data/Import/Ascii par exemple) n’autorise qu’un seul graphe sélectionné.

Une commande importante (et peu intuitive) est le clic droit sur la liste des graphes, qui ouvre un menu comportant les commandes suivantes :

  • focus to : pour définir le graphe actif (utile si plusieurs graphes sont affichés : le graphe actif est celui qui reçoit les actions quand l’utilisateur utilise les icones, de même pour gérer les courbes d’un graphe, il faut que le graphe soit le graphe actif) ;

  • hide : cache le graphe ;

  • show : affiche le graphe ;

  • duplicate : duplique le graphe et toutes ses courbes ;

  • kill : détruit le graphe ;

  • swap : échange deux graphes (il faut deux graphes placés en surbrillance) ;

  • create new : crée un nouveau graphe (vide).

En résumé, pour créer un nouveau graphe, il faut ouvrir la liste des graphes (en utilisant par exemple Plot/Graph Appearance), cliquer à droite sur la liste des graphes et choisir “Create New”). On notera qu’il n’existe pas de menu permettant de faire cette action directement.

3.3. Gestion des courbes#

Le principe de gestion des courbes est à peu près le même que celui concernant les graphes. Grace affiche la liste des courbes (du graphe actif : attention, encore une fois, le graphe actif n’est pas forcément visible !) dans les menus qui manipule les courbes : Edit/Data Sets, Edit/Set Operations, Data/Data set operations, Plot/Set Appearance comme sur l’illustration suivante :

_images/100002010000019F000002D057BE58B897704EE6.png

Le graphe actif est ici G0 (il est rappelé en préfixe des courbes dans la liste), il possède trois courbes (on notera la mention, entre crochet, derrière le nom des courbes de la dimension – ici 2 pour X et Y – et de la longueur – ici, les courbes ont toutes 150 points -).

Dans la liste des courbes, clic droit ouvre un menu :

  • hide : cache la courbe ;

  • show : affiche la courbe ;

  • bring to front : mets la courbe à l’avant-plan ;

  • send to back : mets la courbe à l’arrière-plan ;

  • duplicate : duplique la courbe ;

  • kill : supprime la courbe ;

  • kill data : supprime les données mais pas la courbe, i.e. toute la mise en forme est conservée, ce qui peut être très pratique si l’utilisateur a deux graphes identiques à réaliser à partir de données différentes : il suffit de créer un graphe, puis d’enlever toutes les données avec “kill data”, importer la deuxième série de données : les deux graphes auront exactement le même aspect ;

  • swap : échange la position des deux courbes

  • edit : édite les données ;

  • create new : crée une nouvelle courbe ;

  • pack all sets : ?

  • selector operations : sorte de menu de préférence pour l’affichage de cette liste de courbes.

Remarque :

Toutes les opérations précédentes sur les courbes se font à l’intérieur d’un même graphe. Dans le cas où l’utilisateur aurait besoin de copier une courbe d’un graphe sur un autre, il faut utiliser le menu Edit/Set Operations.