Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2023-04-06 09:36:02

From: Gurgaon
Registered: 2023-02-13
Posts: 24

Problems in installing Code_Aster (tried several different methods!)

Hello everyone,

I have been trying to reinstall Code_Aster ever since my original installation on WSL stopped working, and I have constantly run into issues.

Currently, I am trying to install the Code_Aster for windows edition, from this link: http s://code-aster-windows.com/download/ (kindly remove the space).

I have followed all the steps and complete the installation. However, while running the command: as_run --test forma01a (to test the installation), I face an error as shown in the image.

I would appreciate it if anyone could help me with this error, furthermore I will reply with all the other errors I am facing while trying alternative installations.

installlproblem.png, Size: 98.5 KiB, Downloads: 72


#2 2023-04-07 11:25:18

From: Palaiseau, France
Registered: 2011-07-05
Posts: 149

Re: Problems in installing Code_Aster (tried several different methods!)

Do you have a system-wide python (2.X) installation in your windows ?

In other words, if you open a powershell and just type in "python", does a python 2.X shell open up ?

It seems to me like a conflict between the embedded python (3.7) provided by code-aster-windows and another python 2.0 where the handling of char arrays and strings changed...

Have a look at your system-wide environment variable for any conflict or try to unset the PYTHON* vars...


#3 2023-04-13 12:23:42

Registered: 2021-04-13
Posts: 8

Re: Problems in installing Code_Aster (tried several different methods!)

I currently maintain a Docker image of code_aster 14.6 and 15.2, which works on Windows. I have instructions on my company's website:

http s://www.scimulate.com/containers

My github also has instructions for structuring your analysis and working with results on the native system:

http s://github.com/scimulate/code_aster