Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2022-02-11 08:00:27

aurelius_nero
Member
Registered: 2022-02-11
Posts: 3

[Solved] Error when running salome meca 2021 in GPU mode

Hi all,
Preface:
1) I have singularity installed ( Fedora 35 has it in the repos)
2) All dependencies are installed
3) Installation completed with no issues
4) Salome meca works in software mode

When running:

 ./salome_meca-lgpl-2021.0.0-2-20211014-scibian-9 

I obtain the following output:

 
Illegal option --
Usage: /usr/bin/which [-a] args
**************************************
INFO : Running salome_meca in GPU mode
**************************************
runSalome running on fedora
Searching for a free port for naming service: 2810 - OK
Searching Naming Service  + found in 0.1 seconds 
Searching /Kernel/Session in Naming Service  +++++SALOME_Session_Server: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by /.singularity.d/libs/libGLX.so.0)
Traceback (most recent call last):
  File "/opt/salome_meca/Salome-V2021-s9/modules/KERNEL_V9_7_0/bin/salome/orbmodule.py", line 181, in waitNSPID
    os.kill(thePID,0)
ProcessLookupError: [Errno 3] No such process

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/opt/salome_meca/appli_V2021/bin/salome/runSalome.py", line 694, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/opt/salome_meca/appli_V2021/bin/salome/runSalome.py", line 639, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/opt/salome_meca/Salome-V2021-s9/modules/KERNEL_V9_7_0/bin/salome/orbmodule.py", line 183, in waitNSPID
    raise RuntimeError("Process %d for %s not found" % (thePID,theName))
RuntimeError: Process 3616 for /Kernel/Session not found


--- Error during Salome launch ---

Specs of my computer:

System:
  Host: fedora Kernel: 5.16.7-200.fc35.x86_64 x86_64 bits: 64
    Desktop: Xfce 4.16.0 Distro: Fedora release 35 (Thirty Five)
Machine:
  Type: Laptop System: Dell product: G5 5590 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0KW84T v: A00 serial: <superuser required> UEFI: Dell
    v: 1.12.0 date: 02/07/2020
Battery:
  ID-1: BAT0 charge: 40.3 Wh (69.6%) condition: 57.9/60.0 Wh (96.6%)
    volts: 15.6 min: 15.2
CPU:
  Info: 6-core model: Intel Core i7-9750H bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 800 min/max: 800/4500 cores: 1: 800 2: 800 3: 800
    4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
    v: 510.47.03
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
  Display: x11 server: X.Org 1.20.14 driver: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.5
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Device-2: NVIDIA driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.16.7-200.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi
  IF: wlo1 state: up mac: 28:7f:cf:b0:c2:d7
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: down mac: 8c:04:ba:9a:39:51
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: 28:7F:CF:B0:C2:DB
Drives:
  Local Storage: total: 1.35 TiB used: 18.43 GiB (1.3%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T2B0C-00PXH0
    size: 931.51 GiB
  ID-2: /dev/sda vendor: Western Digital model: WDS480G2G0A-00JH30
    size: 447.13 GiB
Partition:
  ID-1: / size: 929.91 GiB used: 18.22 GiB (2.0%) fs: btrfs dev: /dev/dm-0
  ID-2: /boot size: 973.4 MiB used: 202.5 MiB (20.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 13.8 MiB (2.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 929.91 GiB used: 18.22 GiB (2.0%) fs: btrfs
    dev: /dev/dm-0
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 25.0 C pch: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 304 Uptime: 11m Memory: 31.16 GiB used: 1.87 GiB (6.0%)
  Shell: Bash inxi: 3.3.12

Any and all help is appreciated.

Thank you

Update: I have solved my issue with the help of some people that know Fedora:
1) Ensure Your Nvidia Drivers are installed:
     a) On Fedora enable the RPM Fusion repositories
     

https://rpmfusion.org/Configuration

      b) Install and ensure your Nvidia drivers are up to date
     

https://rpmfusion.org/Howto/NVIDIA

      Please make sure you wait at least 15 minutes after installing the akmod/kmod nvidia packages
      Also ensure secure boot is turned off or the drivers won't be able to load
2) Ensure you have a package called the

nvidia-container-cli

This package ensures your nvidia can be detected by container software
Enable the corresponding repo and get the package

sudo dnf config-manager add-repo https://nvidia.github.io/nvidia-docker/rhel8.5/nvidia-docker.repo && sudo dnf install -y nvidia-container-toolkit

Last edited by aurelius_nero (2022-02-13 01:02:32)

Offline

#2 2022-02-12 02:36:07

aurelius_nero
Member
Registered: 2022-02-11
Posts: 3

Re: [Solved] Error when running salome meca 2021 in GPU mode

Update: Solved my issue, but a small question still persists

A question I have for the developers is why does it say

Illegal option --

as soon as I finish the run command ?

Last edited by aurelius_nero (2022-02-12 22:40:52)

Offline