Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2021-07-29 09:16:42

ing.nicola
Member
Registered: 2017-12-11
Posts: 127

CA 14.6 problem install whit OPENBLAS

Hi ,
i'm trying to install the parallel version following the historycae  guide :
I have installed OPENBLAS 0.3.0 , but when i try to install c.a. serial whit openblas library it fails:

 - install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413b.comm (from astest/zzzz413b.comm)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413b.export (from astest/zzzz413b.export)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413b.med (from astest/zzzz413b.med)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413c.com1 (from astest/zzzz413c.com1)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413c.comm (from astest/zzzz413c.comm)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413c.export (from astest/zzzz413c.export)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz413c.med (from astest/zzzz413c.med)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz414a.comm (from astest/zzzz414a.comm)
- install /home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/share/aster/tests/zzzz414a.export (from astest/zzzz414a.export)
Waf: Leaving directory `/tmp/install_aster.3771/aster-14.6.0/build/std/release'
+ build the elements catalog elem.1 using installed aster (from /tmp/install_aster.3771/aster-14.6.0/build/std/release/catalo/cata_ele.ojb)
stdout: 
stderr: Segmentation fault (core dumped)

To run manually, use:
BINDIR="/home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/bin"
LIBDIR="/home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/lib"
PYTHONDIR="/home/cae/myopt/aster_14_6_0_par/aster_ser/14.6/lib/python3.8/site-packages"
export LD_LIBRARY_PATH="/home/cae/myopt/aster_14_6_0_par/aster_ser/public/hdf5-1.10.3/lib:/home/cae/myopt/aster_14_6_0_par/aster_ser/public/med-4.0.0/lib:/home/cae/myopt/aster_14_6_0_par/aster_ser/public/mumps-5.1.2/lib:/home/cae/myopt/aster_14_6_0_par/aster_ser/public/metis-5.1.0/lib:/home/cae/myopt/aster_14_6_0_par/aster_ser/public/tfel-3.2.1/lib:/home/cae/myopt/aster_14_6_0_par/aster_

Attached the complete log file.


Attachments:
setup.log, Size: 1.48 MiB, Downloads: 38

Offline

#2 2021-07-30 09:09:26

mf
Member
Registered: 2019-06-18
Posts: 261

Re: CA 14.6 problem install whit OPENBLAS

Hello,

I do not know the reason for your error, but Hitoricae uses OpenBLAS 0.2.20,

Mario.


Attachments:
Bildschirmfoto vom 2021-07-30 10-07-31.png, Size: 193.77 KiB, Downloads: 39

Offline

#3 2021-07-30 14:00:45

sameer21101970
Member
Registered: 2019-09-06
Posts: 353

Re: CA 14.6 problem install whit OPENBLAS

w.code-aster.org/forum2/viewtopic.php?id=25201

above thread might help you.

Offline

#4 2021-07-31 13:12:07

nicolo.grilli
Member
From: Bristol, United Kingdom
Registered: 2021-07-30
Posts: 10

Re: CA 14.6 problem install whit OPENBLAS

+ install /home/nicolo/projects/CodeAster/CodeAster14p6/14.6/share/aster/tests/zzzz414a.export (from astest/zzzz414a.export)
Waf: Leaving directory `/tmp/install_aster.44882/aster-14.6.0/build/std/release'
+ build the elements catalog elem.1 using installed aster (from /tmp/install_aster.44882/aster-14.6.0/build/std/release/catalo/cata_ele.ojb)
stdout:
stderr: Segmentation fault (core dumped)

I am getting the same error when I try to use OpenBLAS 0.2.20
Please find attached the list of instructions that I used

Nicolò


Attachments:
InstallationInstructions2.txt, Size: 3.71 KiB, Downloads: 38

Offline

#5 2021-07-31 17:16:32

ing.nicola
Member
Registered: 2017-12-11
Posts: 127

Re: CA 14.6 problem install whit OPENBLAS

Same problem  with OpenBlas 0.2.20.... so i tryed to change version.

sameer21101970 wrote:

w.code-aster.org/forum2/viewtopic.php?id=25201

above thread might help you.

Is the same problem but not solved.

Offline

#6 2021-08-02 09:44:54

nicolo.grilli
Member
From: Bristol, United Kingdom
Registered: 2021-07-30
Posts: 10

Re: CA 14.6 problem install whit OPENBLAS

I did the following to solve the problem:

I do a first installation using the following options in setup.cfg

PREFER_COMPILER ='GNU_without_MATH'
MATHLIB= '/opt/OpenBLAS/lib/libopenblas.a'

In this case the code aster installation fails, but tfel is successfull.

Then I go back to
PREFER_COMPILER ='GNU'

without the MATHLIB line in setup.cfg

I rerun the installation, skipping all the modules already installed, I do only aster installation
and that works fine.
I tried some tests and I could run them successfully.

But now the questions are:
1) If I go on with the procedure for parallel installation, will it work?
2) Can I use successfully MFront if I installed tfel with MATHLIB and aster without?

I attach my installation instructions

Nicolò


Attachments:
InstallationInstructions2.txt, Size: 5.92 KiB, Downloads: 43

Offline

#7 2021-08-02 15:44:44

ing.nicola
Member
Registered: 2017-12-11
Posts: 127

Re: CA 14.6 problem install whit OPENBLAS

nicolo.grilli wrote:

PREFER_COMPILER ='GNU_without_MATH'
MATHLIB= '/opt/OpenBLAS/lib/libopenblas.a'

I tried

PREFER_COMPILER ='GNU_without_MATH'
MATHLIB= '/usr/lib/x86_64-linux-gnu/libblas.a'

Works the installation and the tests.
I hope it is equivalent .. but i have problems whit mumps installation that point to the same library. It give me "segmentation error" during test post installation.

Offline

#8 2021-08-03 10:42:25

nicolo.grilli
Member
From: Bristol, United Kingdom
Registered: 2021-07-30
Posts: 10

Re: CA 14.6 problem install whit OPENBLAS

Hi Nicola

In my case I just run one test case that I copied from the tests folder and it run successfully.
I don't know how to run automated multiple tests, sorry I am really a newbie.
Maybe I would get the same problem.

If that can help, I used Python 3.8.10
I noticed the installation is quite sensitive to the python version.

In my case, I cannot run the mfront executable, even if tfel was compiled successfully.
Running MFront is my main interest.

I have got a suggestion from EDF colleagues to install the entire Salome_Meca 2019 package instead,
as this may install all the packages successfully.

I will keep you updated.

Thank you
Nicolò

Offline