Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2021-02-01 19:48:11

Irvise
Member
Registered: 2019-12-07
Posts: 61

User feedback on Salome_Meca V2020

Hi everyone, specially the Aster/Salome developers,

In this post I would like to give some feedback of my experience with the new version. Feel free to pin it so that other people may add their own experiences.

Also, this post is subject to heavy editing since the more I use the new version, the more I will write. Operating System: OpenSuse Tumbleweed (very up-to-date, bleeding edge distro)

Version 2020.0.1:

[Date 1/2/21]
YACS: I can launch a schema an compute it. But it "never finishes". It indicates that it has finished, however, it won't let me do anything, as if it were running. And it will not stop even if I tell it to "Shutdown Proc". I do not know if this is just my system or others have the same issue. I cannot run YACS at all in the 2019 version either, so that makes me think it is my system.
          The "tutorial" in the documentation cannot be followed since the entry "Add component" of the Catalog (as indicated in the written tutorial) is no longer present. I do not know if this is intended or a bug.

Persalys: it would have been nice to indicate that it is the "new" OpenTURNS interface wink A quick changelog about the new version would be nice.
                When running a YACS model, the option to run several simulations in parallel is ignored. This is an issue that was already present in the V2019 version.

Calculator: none existent response or data about it in the files. Nothing happens when I click on it and I have not found much about that module within the files.

I cannot open the documentation from the Help menu, that also happens in V2019 (to me). Nonetheless the files are available in the installation directory.

I did not have to delete the usual Debian files on my system. So thank you for having fixed that smile

---

As indicated in code-aster.org/forum2/viewtopic.php?id=25443 it would be very, very, very nice to have a more up-to-date Salome version, mostly because of the the new sweet features. The current one is 9.4.0 with some modules being 9.3.0, such as Persalys and ADAO as indicated in the About tab. 9.5.0 is already 6 months old and has quite a few nice improvements. Plus there was already a new version already, 9.6.0. And I also understand that 9.6.0 may be a bit too "new" for a release.

---

Finally, this is more on a personal note. Apart from me wishing that Salome 9.5.0 was used, I fully understand the requirements and the efforts necessary to build/test/run such a massive piece of software. I would like to thank your efforts (developers, R&D and libre software people) for your work that we can use for free.

However, a side of me wishes that there was more commitment or efforts put in the open release. And I think the community could be leveraged more on that one. The Code_Saturne people started adding tutorials on their youtube and have written tutorials in their webpage. I think CA/SM could use some of those ideas. It is very nice that some people took the initiative and create formative material on the net (think Cyprien Rusu or Aether Engineering), but I think you (the developers) can ask the community for some more help.

For example, in testing newer versions for you, so that people who want to use newer features can get them (without any form of warranty, as if there were already one). While people who need a more solid release could get the "normal" one. This way the issues that took place on the V2019 release could have been minimized. Also, the community could be the one tasked with writing a "Notable changes" type of changelog. And official "tutorials" in the youtube channel done by the community could be a very nice addition.

Of course, this is a work of passion, and the software is given as is. I just think that CA could use the community a bit more on its favour. I personally spend a few hours a month helping people here on the forums to make the learning experience less bitter and created the OpenTURNS tutorials since there was next to nothing in the documentation, which the community could help with too wink

(BTW, I am also giving a talk this Sunday in FOSDEM about libre mechanical software, and of course, you are highly featured there. Bringing awareness in my humble opinion is also useful)

---

Anyhow, I am very glad for your continuous work and commitment to helping others in an altruistic manner. Thank you very, very, a lot, very, more than very much for the new release!

Kind regards,

Fer

[EDIT 1]: added another bug/issue to Persalys/OpenTURNS
[EDIT 2]: also, I just noticed that you have added a parametric tab in the "History View" section for Persalys and ADAO, that is very, very nice. Thank you. I really need to get my hands on ADAO and HOMRAD to start doing some topology optimization! A nice written guide would be very much appreciated wink
[EDIT 2.5]: I have tried to give the parametric study tab a try. I cannot run any parametric study since it keeps telling me that I am lacking a "NOM_PARA" in the "IMPR_TABLE" when I clearly have one. It is the same file I used in the video. Since this is and edit, I cannot upload the file, I will make a new comment.

Last edited by Irvise (2021-02-01 21:02:36)

Offline

#2 2021-02-01 21:03:38

Irvise
Member
Registered: 2019-12-07
Posts: 61

Re: User feedback on Salome_Meca V2020

Go directly to the AsterStudy section. You may need to update the paths of the mesh and the output table.


Attachments:
tmp.zip, Size: 761.39 KiB, Downloads: 107

Offline

#3 2021-02-03 17:19:58

GPSalachs
Member
Registered: 2018-03-10
Posts: 244

Re: User feedback on Salome_Meca V2020

Day : 03/02/2021
I would like to report the same kind of response from the Salome_Meca 2020 for the Persalys and ADAO.
The error message i am also encountering is the following " NOM_PARA not defined in the selected IMPR_TABLE command " . While it is defined.
The same response as above is encountered with the "Calculator" tab that isn't affected or can be affected by anything. Non responsive.
Other errors at the moment of this post were not encountered.

The configuration of the machine that the software is installed is presented :

Ubuntu version 18.04.5 LTS
Processor : Intel® Core™ i7-2630QM CPU @ 2.00GHz × 8
Graphics :  Intel® HD Graphics 3000 (SNB GT2)
GNOME : 3.28.2
OS type 64-bit .

Hope these specifics can help a little bit.

Thank you very much for all the hard work!!

Best Regards,

GPSalachs.

Last edited by GPSalachs (2021-02-03 17:22:43)

Offline