Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-09-17 18:09:37

Liu Shibo
Member
Registered: 2020-06-30
Posts: 3

How to configure ssh to let ASTK run in my computer?

How to configuration for ASTK

Hello everyone,

I am new to Code_Aster. After installation of the software, I begin to learn it according to the book of Jean-Pierre Aubry. The book name is “Beginning with code_aster A practical introduction to finite element method using code_aster and Gmsh”.

Now I meet my first problem that I cannot solve it alone. After step by step learning of the book, in Chapter 5, when I begin to compute the test case through ASTK, I found that I cannot run it.

I have read the topic on   

    Index  » Code_Aster installation  » [SOLVED]ssh configuration

and topic:

    Index  » Code_Aster installation  » Issue to launch calculation with ASTK, after previously working set-up


There must be some problem with my ssh setup.
When I run ASTK, I got the information that tells me something is wrong.
I attach the relevant information in a .txt file (too long to put here). Please check it.

-------------------------------

PS:

I install Aster14.4.0 on Ubuntu 18.04.5 LTS.
My computer name is "shibo"
My account is "shibo"
I installed Code_Aster in /opt/aster14 just as the book's instruction.
And the configuration is also according to the book as:

-----------------------------
In the ASTK window, menu Configuration
Preferences
Network :
• the Client machine name field should be the machine name, which
can be obtained by typing the command ’hostname’ in a terminal;
• the Domain name can be left empty;
• Forced DISPLAY variable can be set to:0.0 ;
• and button ssh and scp pushed on.
-----------------------------

About configuration of ssh:
I generate the ssh key in the “/home/shibo” which is also my “~”.

shibo@shibo:~$ cd .ssh
shibo@shibo:~/.ssh$ ls
authorized_keys  id_rsa  id_rsa.pub

And in “~/.ssh” I have added id_rsa.pub into authorized_keys

To let the ssh connect successfully, I think I should add my “id_rsa.pub” into the server’s “authorized_keys”, but I don’t know where should I add id_rsa.pub to?

Add the “id_rsa.pub” to “/opt/Aster14/.ssh/authorized_keys”? I have tried but it didn’t work.

Add the “id_rsa.pub” to “/tmp/astk_root/.ssh/authorized_keys”? I have also tried but it didn’t work.

So what should I do to run ASTK?

Really thank you if you can give me some instructions, this problem has tortured me for two weeks.

I really appreciate your instructions.


Attachments:
Astk_message.txt, Size: 8.12 KiB, Downloads: 18

Offline