Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-08-13 17:15:46

Registered: 2020-06-22
Posts: 13

[SOLVED] as_run config.txt not found

Hello everyone,

In order to automate my simulation process I'm trying to run my first study outside of the nice AsterStudy interface.
To to this I've used the export feature from AsterStudy and created three files with .med, .comm and .export.
From what I understand I should be able to run the calculation using the as_run script with the .export file as a parameter.
When I execute as_run, I've installed code_aster both as a standalone and as a part of salome_meca I get the following error:

~/salome_meca/V2019.0.3_universal/tools/Code_aster_frontend-20190/bin/as_run --serv CurrentCase.export 

<F>_FILE_NOT_FOUND file not found : config.txt



I have been able to locate the config.txt file in the locations where I'm guessing it should be:

x@y:~$ find ./ -name config.txt

So my guess is that somewhere in profile or a setting or something the information about the directory where config.txt is, is missing. I assume it's some system variable that's missing.
Does anyone know how I can tell code_aster where to look? Any help would be greatly appreciated.

Thanks in advance,


Last edited by PtK (2020-08-14 12:21:21)


#2 2020-08-14 12:32:10

Registered: 2020-06-22
Posts: 13

Re: [SOLVED] as_run config.txt not found

I solved it. My code_aster installation was completely fine. The reason was that the .export file which I created by using the <Export Case> function in AsterStudy was missing necessary parameters for the calculation:

P memory_limit 2048
P mpi_nbcpu 1
P mpi_nbnoeud 1
P ncpus 0
P server localhost
P testlist verification sequential
P time_limit 900
F comm calc_freq.comm D  1
F libr calc_freq.med D  4

After running the study in AsterStudy and looking at the export file located at RunCase_1/Result/export I found a functioning .export file:

P actions make_etude
P debug nodebug
P memjob 2097152
P memory_limit 2048.0
P mode interactif
P mpi_nbcpu 1
P mpi_nbnoeud 1
P ncpus 0
P nomjob RunCase_1_calc_freq
P origine AsterStudy 0.11
P rep_trav /tmp/ws-spmd-ws-interactif_29932
P server localhost
P studyid 12539-0001-spmd-ws
P time_limit 900.0
P tpsjob 16
P version stable
A memjeveux 256.0
A tpmax 900.0
F comm RunCase_1_calc_freq.comm D  1
F libr _ExportedFromSalomeObject_0_1_2_3.med D  4
F libr calc_freq.rmed R  80
F libr freq_tab.csv R  2
F mess message R  6
R base base-stage1 R  0

This now runs perfectly using as_run smile
Is this a bug in AsterStudy that per default the <Export Case> function creates an export file which cannot be used with as_run or is this intentional?