Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-08-12 10:31:36

Registered: 2020-06-22
Posts: 13

[SOLVED] code_aster solver not found flasheur directory permissons

Hello everyone,

I'm posting about solved problem since it cost me almost a whole day yesterday and I didn't find any posts about it here.
I'm working on a brand new machine, installed Ubuntu 18.04.4 LTS. During the setting up of the machine and installing the drivers and components I also installed Salome_Meca.
After the installation I tested Salome_Meca and got the following error when opening the AsterStudy module:

No available versions found on 'localhost'.
Previous server is selected: ''.

I tried re-installing numerous times and always made sure to delete the temporary and config directories .cache and .config but nothing worked.
Finally the solution was that on the first install I must've accidentally used sudo to install and the empty flasheur/ directory created upon installing was owned by root and not my local user. I changed the owner of the directory to my local user and everything worked perfectly.

Maybe this will spare someone an afternoon of frustration in the future.