Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-10-20 00:18:28

Beda17
Member
Registered: 2019-10-19
Posts: 2

SalomeMeca2019 on Fedora 31

Dear developers and community,

I have issues installing salome meca on Fedora 31.
After running $ tar xvf salome_meca-2019.0.1-1-LGPL.tgz && ./salome_meca-2019.0.1-1-LGPL.run, a appli_V2019_univ/salome was not even created. bash -x of the installation is attached.

For what I have done till know to get it at least installed see bellow. I was initially writing it as a how to, for the case I would have succeeded:
 
After the installation failed the installer content is extracted in V2019_univ, we do not need to repeat it:
1) extract the script from the installer
$ head -756 salome_meca-2019.0.1-1-LGPL.run > salome_script.sh

2) comment out ("#") the archiv extractions (we already have it): line 523, 527-540
$ vi salome_script.sh
press "i" for edit mode

#tail -n+$ARCHIVE "$0" > "$TARGETDIR"/V2019_univ.tgz
#
cd "$TARGETDIR"
#
#check "$TARGETDIR"/V2019_univ.tgz "$VERBOSE"
#
#if test "$QUIET" = "y"; then
#  tar xzf V2019_univ.tgz
#else
#  if test "$VERBOSE" = "y"; then
#    tar xvzf V2019_univ.tgz
#  else
#    bar_cat V2019_univ.tgz
#  fi
#  echo "Done"
#fi
#
#rm V2019_univ.tgz

3) manualy change APPLIDIR (line 45) and add SALOMEDIR (around line 103)
$ vi ${HOME}/salome_meca/V2019_univ/create_appli.sh
pres "i" for edit

...
  fi
}

APPLIDIR="${HOME}/salome_meca/appli_V2019_univ" # change this line
TEMPDIR="/tmp"
DESKTOP="y"
...

...
  esac
done

SALOMEDIR=${HOME}/salome_meca/V2019_univ    # add this line

if test -z "$SALOMEDIR"; then
  SALOM
...

4) link libstdc++.so.6 Fedora has a different path
$ cd ${HOME}/salome_meca/V2019_univ/prerequisites/debianForSalome/lib
# backup original one
mv libstdc++.so.6{,.old}
# link the system library
$ ln -s /usr/lib64/libstdc++.so.6

5) install nlop
$ sudo dnf install NLop

Unfortunately even after installing qt5 ($ sudo dnf install qt5 qt5-qtbase qt5-qtbase-devel) I still have issues running salome meca:

Searching for a free port for naming service: 2814 - OK
Searching Naming Service  + found in 0.1 seconds
Searching /Kernel/Session in Naming Service  +++++Warning: this type (Study,objref) already exists, it will be ignored.
+++ found in 4.0 seconds
Start SALOME, elapsed time :   4.2 seconds
Traceback (most recent call last):
  File "/home/beda/salome_meca/appli_V2019_univ/lib/python3.6/site-packages/salome/salome_pluginsmanager.py", line 94, in <module>
    import SalomePyQt
ImportError: /lib64/libQt5Core.so.5: version `Qt_5_PRIVATE_API' not found (required by /home/beda/salome_meca/V2019_univ/prerequisites/Pyqt-590/lib/python3.6/site-packages/PyQt5/QtCore.so)

It is a great software, thank you for your work. Flatpak would be an interesting solution, there was even some thinkering few years ago.

Thank you in advanced


Attachments:
salome_install_log.txt, Size: 656.97 KiB, Downloads: 29

Offline

#2 2019-10-20 00:44:46

Beda17
Member
Registered: 2019-10-19
Posts: 2

Re: SalomeMeca2019 on Fedora 31

Not to forget I already tried exporting the path bellow as mention in thread id=24470.
export LD_LIBRARY_PATH=~/salome_meca/V2019_univ/prerequisites/Qt-591/lib:$LD_LIBRARY_PATH

It might be related to the installation syntax error I am still getting in salomemeca_custom_appli.py. I thought it would be related python 2 vs 3, that is why I tried $ alias python=python2 before running the installation, without luck.

salome_meca post-installation ...
  File "/home/beda/salome_meca/V2019_univ/salomemeca_custom_appli.py", line 19
    print "exactly one argument is expected (APPLIDIR)"
                                                      ^
SyntaxError: invalid syntax
Warning: the directory /home/beda/salome_meca/V2019_univ/modules/EUROPLEXUS_20190/lib/salome is in a path variable but does not exist
Warning: the directory /home/beda/.local/bin is in a path variable but does not exist

Offline

#3 2020-02-24 10:42:00

Bruc69
Member
Registered: 2020-02-24
Posts: 1

Re: SalomeMeca2019 on Fedora 31

Dear Beda17,
I have followed exactly all your instructions, and for me it worked. I was able to use entirely Salome-Meca 2019 without problems. I must sincerely thank you, with this occasion, for your very accurate instructions.

But when I tried  all that stuff, in Fedora 31, for the previous version of Salome Meca (2018), I was able to install it, but it didn't start. By pure chance, I have discovered why: the problem was the version of python! In Fedora 31 the default version is python 3, they emphasis the fact they massively drop out python 2. In Ubuntu Bionic (recommended on the official site), the default version is still python 2.

The trick that I have used was to install python 2, alongside python 3, in Fedora 31, and to put a symbolic link of "python2" from "/usr/bin" to "~/bin" with name "python" . ($PATH must contain "$HOME/bin" before "/usr/bin". I have made by myself the folder "bin" in my Home directory )
So, the default version for the user is python 2.
After that, I have reinstalled, with no problem, the original form of Salome Meca installation kit, for both versions: 2018 and 2019. And they both worked like a charm.


In case of some problems (which I suppose that are very probably to occur) with other software, you can just rename the link "pyhton" in $HOME/bin , and the default python version become again 3. (Salome Meca 2019 worked for me with python 3, but Salome Meca 2018 didn’t. I believe that in your case, the problem was python 3. I also believe that it is safer to have the default version python 2, for the user, when you work with Salome Meca/code Aster. I must mention that I have used a XFCE version, downloaded from official site, for Fedora 31. Also, the renaming of libstdc++.so.6, that you have specified in your post,  was necessary on machines with ATI display adapter, and no necessary on a machine with a NVIDIA display adapter, at least on those that I have tried)

Best regards

Offline