Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-01-14 10:09:41

Olivier_Gomes
Member
Registered: 2019-10-04
Posts: 3

Post-Traitement des EFGE_ELNO d'une GRILLLE_EXCENTREE

Bonjour,


Je me retrouve actuellement confronté à un problème concernant le post-traitement des EFGE_ELNO de GRILLE_EXCENTREE.



Le modèle :

     --> Il s'agit d'une dalle de 5.00m de longueur, de 3.00m de largeur et 25cm d'épaisseur.
     --> Une fois maillée, je duplique 4 fois ces mailles. J'ai donc un total de 5 mailles identiques et superposées.
     --> Sur la maille d'origine j'affecte une modélisation DKT et une loi de comportement du type MAZARS issue de la commande DEFI_MATER_GC.
     --> Sur les 4 mailles dupliquées (aciers inf X et Y et aciers sup X et Y), j'affecte une modélisation GRILLE_EXCENTREE et une loi de comportement du type ACIER issue de la commande DEFI_MATER_GC.
     --> Ligne d'appui OUEST : DX=DY=DZ=0
     --> Ligne d'appui EST : DZ=0
     --> J'applique une pression surfacique sur l'ensemble.
     --> Résolution avec STAT_NON_LINE



Mon problème :

Je souhaite connaitre les EFGE_ELNO dans l'ensemble de ma section béton armé. Pour ce faire je procède ainsi :

RESU=CALC_CHAMP(reuse=RESU,
                                  RESULTAT=RESU,
                                  CONTRAINTE='EFGE_ELNO',
                                  GROUP_MA=('ixDA101','iyDA101','sxDA101','syDA101','DA101'),),);

IMPR_RESU(FORMAT='RESULTAT',
                    UNITE=86,
                    RESU=(_F(RESULTAT=RESU,
                                      INST=1.00,),),);

Cependant, quand j'observe les EFGE_ELNO je constate la présence d'un effort normal dans la section assez conséquent. Je décide donc de séparer le post-traitement des ''aciers'' et du ''béton'' afin d'avoir une meilleur vision de ce qui se passe dans mon modèle. J'ai donc 3 sorties différentes de EFGE_ELNO :
    (1)  ---> Béton + Acier
    (2)  ---> Béton
    (3)  ---> Acier

J'obtiens pour (1) et (2) des résultats identiques, ce qui à première vu me parait incohérent dans ma configuration.
Pour (3) j'ai le message d'alarme suivant :

   
   !--------------------------------------------------------------------------------------------------!
   ! <A> <CALCULEL2_89>                                                                               !
   !                                                                                                  !
   !  Alarme utilisateur :                                                                            !
   !    Le champ  EFGE_ELNO  n'a pas pu être calculé.                                                 !
   !                                                                                                  !
   !  Risques & conseils :                                                                            !
   !    * Si le champ est un champ par éléments, c'est que le calcul élémentaire n'est pas disponible !
   !      pour les éléments finis utilisés. Cela peut se produire soit parce que ce                   !
   !      calcul n'a pas été encore programmé, soit parce que ce calcul n'a pas de sens.              !
   !      Par exemple, le champ EFGE_ELNO n'a pas de sens pour les éléments de la modélisation '3D'.  !
   !    * Si le champ est un champ aux noeuds (XXXX_NOEU), cela veut dire que le champ XXXX_ELNO      !
   !      n'existe pas sur les éléments spécifiés.                                                    !
   !      Par exemple, le calcul de SIGM_NOEU sur les éléments de bord est impossible.                !
   !                                                                                                  !
   !                                                                                                  !
   ! Ceci est une alarme. Si vous ne comprenez pas le sens de cette                                   !
   ! alarme, vous pouvez obtenir des résultats inattendus !                                           !
   !--------------------------------------------------------------------------------------------------!
   

J'en conclu que les EFGE_ELNO ne sont pas exploitables ainsi pour les GRILLE_EXCENTREE, cependant pour (1) qui post-traite également ces GRILLE_ESCENTREE je n'ai pas cette alarme.

De plus, le §8.1 de la doc U3.12.04 indique que les EFGE_ELNO sont post-traitable pour des grilles excentrées.



Conclusion :

Je cherche donc à savoir :
   ---> comment pourrais-je post-traiter les EFGE_ELNO de mes grilles excentrées ?
   ---> les résultats que j'obtiens pour (1) semblent ne contenir que les informations liées au béton. Cela vous parait-il cohérent ?


Merci par avance,
Olivier.

Offline