Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-12-07 02:02:41

kaengo
Member
From: Germany - Schleswig-Holstein
Registered: 2016-11-25
Posts: 27

Installation on CentOS 8

Hello!

I tried once ago to install SalomeMeca 2019 on Centos 8
But I get:

[kaengo@kraehe salome_meca]$ export PATH=/usr/bin:$PATH
[kaengo@kraehe salome_meca]$ alias python=/usr/bin/python2.7
[kaengo@kraehe salome_meca]$ unset PYTHONPATH
[kaengo@kraehe salome_meca]$ export PYTHONHOME=/usr
[kaengo@kraehe salome_meca]$ ./salome_meca-2019.0.1-2-LGPL.run

[kaengo@kraehe salome_meca]$ python --version
Python 2.7.15
[kaengo@kraehe salome_meca]$ ./salome_meca-2019.0.1-2-LGPL.run

================================================
Self Extracting salome_meca V2019_univ Installer
================================================

Enter the salome_meca install directory [default=/home/kaengo/salome_meca] :
salome_meca is in English, do you want to be in French ? [y/N] :
Installation of salome_meca V2019_univ in /home/kaengo/salome_meca/V2019_univ ...
Verifying archive integrity...
All good.
Done                                                                                                                           
./create_appli.sh: line 108: /salome_prerequisites_root.sh: No such file or directory
./create_appli.sh: line 109: /salome_modules.sh: No such file or directory
Creating salome_meca application in /home/kaengo/salome_meca/appli_V2019_univ ...
sed: can't read /.config_appli_template.xml: No such file or directory
Setting for help already set
grep: salome_context.cfg: No such file or directory
salome_meca post-installation ...
./create_appli.sh: line 263: python: command not found
Warning: the directory /home/kaengo/.local/bin is in a path variable but does not exist
Warning: the directory /home/kaengo/bin is in a path variable but does not exist
Warning: the directory /home/kaengo/.local/bin is in a path variable but does not exist
Warning: the directory /home/kaengo/bin is in a path variable but does not exist
./create_appli.sh: line 287: ./salome_post_install.py: No such file or directory
The salome_meca application was successfully created.
To run the application:
$ /home/kaengo/salome_meca/appli_V2019_univ/salome
Adjusting wishexecutable /home/kaengo/salome_meca/V2019_univ/tools/Code_aster_frontend-20190/etc/codeaster/profile.sh
Initialize terminal and editor for Code_aster
Final configuration
[kaengo@kraehe salome_meca]$

I reinstalled python 2 and tried again before this run.

Does anyone know the solution?


Greetings,
Holger

Edit:
I tried once ago the actual fedora 31 distro (in vmware).
Same failure ....

Last edited by kaengo (2019-12-08 16:11:27)

Offline

#2 2020-01-26 16:53:38

virengos
Member
From: Stuttgart
Registered: 2017-01-16
Posts: 3

Re: Installation on CentOS 8

Dear code_aster experts,
I'm a happy Salome 9.3 / 9.4 user on Ubuntu and Fedora, now it's time to get familiar with code_aster.
In the last few weeks, I tried to install Salome Meca 2017-2019 on fresh installed Fedora 31 and CentOS 7.7/8.1 Linux distros. Unfortunately without success. Always the same known errors, as already reported by other users here.

I'm not the greatest Linux guru. But after some years of experience, I'm less or more familiar with the standard issues, debugging and troubleshooting.
Is it possible to get some more detailed info about the Linux distros and the Salome software has been developed and tested?
Distro / release number Linux, Salome, code aster / configuration / ~hardware ?

I'm feeling really motivated to run more checks and sharing my knowledge with the community.
Best regards,
Damian

Offline

#3 2020-03-21 15:49:40

suroy2005
Member
Registered: 2020-03-21
Posts: 1

Re: Installation on CentOS 8

Instruction for installing salome_meca under centos-8.2

export SALOMEDIR=/opt/SALOME/salome_meca/V2019.0.3_universal
export APPLIDIR=/opt/SALOME/salome_meca/appli_V2019.0.3_universal
export HOME=/opt/SALOME
./salome_meca-2019.0.3-1-universal.run


output is given bellow:

=========================================================
Self Extracting salome_meca V2019.0.3_universal Installer
=========================================================

Enter the salome_meca install directory [default=/opt/SALOME/salome_meca] :
The directory /opt/SALOME/salome_meca/V2019.0.3_universal already exists, install anyway ? [y/N] y
salome_meca is in English, do you want to be in French ? [y/N] : y
Installation of salome_meca V2019.0.3_universal in /opt/SALOME/salome_meca/V2019.0.3_universal ...
Verifying archive integrity...
All good.
Done                                                                                                                                     
Creating salome_meca application in /opt/SALOME/salome_meca/appli_V2019.0.3_universal ...
Desktop directory not found.
Setting for help already set
Setting the language to fr in the preferences file /opt/SALOME/.config/salome/SalomeApprc..universal
salome_meca post-installation ...
  File "/opt/SALOME/salome_meca/V2019.0.3_universal/salomemeca_custom_appli.py", line 19
    print "exactly one argument is expected (APPLIDIR)"
                                                      ^
SyntaxError: invalid syntax
Warning: the directory /opt/SALOME/salome_meca/V2019.0.3_universal/modules/EUROPLEXUS_201901/lib/salome is in a path variable but does not exist
The salome_meca application was successfully created.
To run the application:
$ /opt/SALOME/salome_meca/appli_V2019.0.3_universal/salome
Adjusting wishexecutable /opt/SALOME/salome_meca/V2019.0.3_universal/tools/Code_aster_frontend-20190/etc/codeaster/profile.sh
Initialize terminal and editor for Code_aster
Creating symlink in /opt/SALOME/salome_meca/V2019.0.3_universal/tools/Code_aster_stable-v144_smeca : salome -> /opt/SALOME/salome_meca/appli_V2019.0.3_universal/salome
Final configuration

Offline