Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-05-15 04:48:44

blckwtr
Member
Registered: 2017-02-23
Posts: 10

error launching salome-meca after install

runSalome running on blckwtr-Latitude-E6410
INFO:MainThread:Problem loading PortManager file: /tmp/.salome_PortManager.cfg
INFO:PortManager:Problem loading PortManager file: /tmp/.salome_PortManager.cfg
Error when trying to access active network connections.
Traceback (most recent call last):
  File "/home/blckwtr/salome_meca/appli_V2018.0.1_public/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort
    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)
  File "/home/blckwtr/salome_meca/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/home/blckwtr/salome_meca/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Searching for a free port for naming service: 2810 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service ++++
(SALOME_Session_Server:27997): Gtk-WARNING **: 05:44:58.286: Unable to locate theme engine in module_path: "adwaita",

(SALOME_Session_Server:27997): Gtk-WARNING **: 05:44:58.296: Unable to locate theme engine in module_path: "adwaita",
+libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
+libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.
+Traceback (most recent call last):
  File "/home/blckwtr/salome_meca/appli_V2018.0.1_public/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/blckwtr/salome_meca/appli_V2018.0.1_public/bin/salome/runSalome.py", line 578, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/blckwtr/salome_meca/V2018.0.1_public/modules/KERNEL_V8_5_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 27997 for /Kernel/Session not found


--- Error during Salome launch ---

Offline

#2 2019-05-15 08:13:58

GPSalachs
Member
Registered: 2018-03-10
Posts: 250

Re: error launching salome-meca after install

Have a look at this post https:/_/code-aster.org/forum2/viewtopic.php?pid=57106#p57106

Offline