Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2018-08-21 16:02:18

pksri31
Member
From: Finand
Registered: 2017-09-30
Posts: 2

Code Aster not working in Ubuntu 18.04

Hi,
I installed Salome meca based on the below following comment given by Mr.Thomas

Thomas DE SOZA wrote:

    Hello,

    It seems like the system Python is being superseded by your custom installation.

    I suggest you set the following before running the Salome-Meca installer (quick and dirty):

    export PATH=/usr/bin:$PATH
    alias python=/usr/bin/python2.7 (or whatever is the name of your Python2 executable)
    unset PYTHONPATH
    export PYTHONHOME=/usr

    TdS

I followed your suggestion and now the installation was good. However, the application is not launching! I tried to launch the application from the ./salome and I am getting below following error.

File "/home/kumar/salome_meca/appli_V2018/.salome_run", line 41
    print "ERROR: unexisting configuration/environment file(s): " + ', '.join(unexisting)
                                                                ^
SyntaxError: invalid syntax

I started salome again by defining python 2.7 and I am getting the error as attached.


kumar@kumar-HP-Pavilion-dv6-Notebook-PC:~/salome_meca/appli_V2018$ export PATH=/usr/bin:$PATH
kumar@kumar-HP-Pavilion-dv6-Notebook-PC:~/salome_meca/appli_V2018$ alias python=/usr/bin/python2.7
kumar@kumar-HP-Pavilion-dv6-Notebook-PC:~/salome_meca/appli_V2018$ unset PYTHONPATH
kumar@kumar-HP-Pavilion-dv6-Notebook-PC:~/salome_meca/appli_V2018$ export PYTHONHOME=/usr
kumar@kumar-HP-Pavilion-dv6-Notebook-PC:~/salome_meca/appli_V2018$ ./salome
runSalome running on kumar-HP-Pavilion-dv6-Notebook-PC
Error when trying to access active network connections.
Traceback (most recent call last):
  File "/home/kumar/salome_meca/appli_V2018/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort
    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)
  File "/home/kumar/salome_meca/V2018/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/home/kumar/salome_meca/V2018/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Searching for a free port for naming service: 2814 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service +++Gtk-Message: 20:18:22.922: Failed to load module "canberra-gtk-module"
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.
+Traceback (most recent call last):
  File "/home/kumar/salome_meca/appli_V2018/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/kumar/salome_meca/appli_V2018/bin/salome/runSalome.py", line 578, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/kumar/salome_meca/V2018/modules/KERNEL_V8_5_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 18969 for /Kernel/Session not found

--- Error during Salome launch ---

Any  guidance would be helpful. Thank you so much

Offline

#2 2019-03-19 09:42:55

DavidS
Member
Registered: 2019-03-16
Posts: 3

Re: Code Aster not working in Ubuntu 18.04

Dear Sirs,

I do have exactly the same problem.
I am surprised, how difficult and time consuming it is to install this package.
Any help is appreciated.

kind regards,
David.

Offline

#3 2019-03-19 10:07:43

GPSalachs
Member
Registered: 2018-03-10
Posts: 181

Re: Code Aster not working in Ubuntu 18.04

Hello, look at this thread :

https:/ / www .code-aster.org/forum2/viewtopic.php?id=24042

seems like you have the same problems.

Offline

#4 2019-03-26 10:47:24

riyasathe
Member
Registered: 2019-03-26
Posts: 1

Re: Code Aster not working in Ubuntu 18.04

GPSalachs wrote:

Hello, look at this thread :

https:/ / www .code-aster.org/forum2/viewtopic.php?id=24042

seems like you have the same problems.

Thank you for this link. I had the same problem. Great help.


https://crbtech.in/online-java-training-course

Offline