Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2016-12-21 13:48:09

From: Strasbourg (France)
Registered: 2012-10-15
Posts: 70

Build 12.6 parallel on ubuntu 14.04 - Error with mpi


I have tried to build the parallel version of CA_12.6 on ubuntu 14.04.
Despite the fact that every was OK with scalapack, openblas, petsc, ... when I install the parallel version of CA I obtain the following message.

Waf: Leaving directory `/home/aster/Install_Files/12.6/aster-full-src-12.6.0/SRC/aster-12.6.0/build/release'
+ build the elements catalog elem.1 using installed aster (from cata_ele.ojb)
stdout: # ------------------------------------------------------------------------------------------
# Impression du contenu du fichier de commandes à  exécuter :
# ------------------------------------------------------------------------------------------

# ------------------------------------------------------------------------------------------
   ! <F> <JEVEUX1_71>                                                                       !
   !                                                                                        !
   !  La mémoire totale de 4000.00 Mo allouée à l'étude est insuffisante, il est nécessaire !
   !  de disposer d'au moins 29360.35 Mo uniquement pour démarrer l'exécution.              !
   !                                                                                        !
   !                                                                                        !
   ! Cette erreur est fatale. Le code s'arrête.                                             !

 La mémoire demandée au lancement est sous estimée, elle est de 4000.00 Mo.
 Le pic mémoire utilisée est de 29360.36 Mo.

End of the Code_Aster execution
Code_Aster MPI exits with errors

stderr: #0  0x7fe93bcdb642

I don't know where does the value of 29Go come from. The workstation has only 16Go of RAM.

Actually, I was using CA_12.4 parallel and everything was runing well. After an update of the workstation, suddenly I was not able to launch a parallel calculation with mpi. Each time I obtain the same error message.

I thought that I have to rebuild from scratch the parallel version that's why i decide to go to 12.6 and to build it directly parallel.

I guess now, that the issue doesn't come from the installation but from the update. I don'y which package has been updated and prevent the use of mpi.

I think this is the same issue as this topic: https://code-aster.org/forum2/viewtopic.php?id=21109

Thanks for your help



#2 2016-12-22 11:12:36

From: Strasbourg (France)
Registered: 2012-10-15
Posts: 70

Re: Build 12.6 parallel on ubuntu 14.04 - Error with mpi


I have progressed a little bit with my issue.

I was using the openmpi native version of ubuntu 14.04 which is the version 1.6.
I have removed this version and I have build and install the version 2.0.

After that, I have rebuild code_aster v12.4 and V12.6 (both serial and parallel).

I had an alarm during the compilation of petsc during the test on 2 MPI process on a c/c++ test.
Nevertheless, I have made some tests and now the actual status is :
- Version 12.4 is working
- Version 12.6 is not working due the fact that MED and HDF librairies are not installed.

When I launch the v12.6 I obtain the following message

              -- CODE_ASTER -- VERSION : EXPLOITATION (stable) --               
                     Version 12.6.0 modifiÉe le 16/06/2016                      
                     révision 77d3379d51e8 - branche 'v12'                      
                         Copyright EDF R&D 1991 - 2016                          
                    ExÉcution du : Thu Dec 22 09:23:50 2016                     
                           Nom de la machine : AsterX                           
                              Architecture : 64bit                              
                          Type de processeur : x86_64                           
      Système d'exploitation : Linux Ubuntu 14.04 trusty 3.19.0-75-generic      
                        Langue des messages : fr (UTF-8)                        
                           Version de Python : 2.7.6                            
                            Version de NumPy : 1.8.2                            
                            ParallÉlisme MPI : actif                            
                         Rang du processeur courant : 0                         
                       Nombre de processeurs utilisÉs : 1                       
                          ParallÉlisme OpenMP : actif                           
                        Nombre de processus utilisÉs : 1                        
                        Librairie HDF5 : non disponible                        
                         Librairie MED : non disponible                         
                       Librairie MFront : non disponible                        
                     Version de la librairie MUMPS : 4.10.0                     
                    Version de la librairie PETSc : 3.4.5p0                     
                    Version de la librairie SCOTCH : 5.1.10                     

                 MÉmoire limite pour l'exÉcution : 15250.00 Mo                  
                   consommÉe par l'initialisation : 561.07 Mo                   
                  par les objets du jeu de commandes : 3.34 Mo                  
                reste pour l'allocation dynamique : 14684.32 Mo                 
                Taille limite des fichiers d'Échange : 12.00 Go  

It seems that it is more or less similar to the topic : https://code-aster.org/forum2/viewtopic.php?id=20371.

Up to now I did not try to rebuild openmpi with the static library due to the fact that I have to do a calculation.