Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2014-10-15 14:53:20

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Problem with COMB_SISM_MODAL

Hi everyone,

I have a problem with the Command COMB_SISM_MODAL. I want to do a response spectrum analysis of a structure:

modal = COMB_SISM_MODAL(MODE_MECA=MODES,
			TOUT_ORDRE='OUI',
			AMOR_REDUIT=0.05,
			MONO_APPUI='OUI',
			EXCIT=_F(TRI_SPEC='OUI',
			         SPEC_OSCI=(speH, speV, speH,),
				     ECHELLE=(1000, 1000, 1000,),),
			COMB_MODE=_F(TYPE='SRSS',),
			OPTION=('DEPL','REAC_NODA',),);

The calculation of the displacements works fine but i cant calculate any stresses. I always get this error message:

   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
   ! <S> Exception utilisateur levee mais pas interceptee.                           !
   ! Les bases sont fermees.                                                         !
   ! Type de l'exception : error                                                     !
   !                                                                                 !
   !  Erreur utilisateur :                                                           !
   !    Le programme a besoin d'accéder au champ REAC_NODA de la structure           !
   ! sd_resultat MODES                                                               !
   !    pour le NUME_ORDRE: 9223372036854775807                                      !
   !    Mais ce champ n'existe pas dans la structure de données fournie.             !
   !    On ne peut pas continuer.                                                    !
   !                                                                                 !
   !  Risques & conseils :                                                           !
   !  Vérifiez que la structure de données MODES est bien celle qu'il faut utiliser. !
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

See attached the mess-file.

I hope you can help me because i don't know where is my bug.



Sincerely,

Tobi


Attachments:
Modal.mess, Size: 129.86 KiB, Downloads: 223

Offline

#2 2014-10-15 23:03:41

delmas
Administrator
From: EDF R&D
Registered: 2007-12-12
Posts: 837

Re: Problem with COMB_SISM_MODAL

It's a bug. Please post your files to reproduce the problem.


Code_Aster release : unstable on (Ubuntu Precise Pangolin 12.04 64 bits) - GNU + Intel

Code_Aster. What else ?

Offline

#3 2014-10-16 10:37:23

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Re: Problem with COMB_SISM_MODAL

Hello,

you can download the files here: https://www.dropbox.com/s/wij1tweee20ws … l.zip?dl=0
The model is a bit different but the problem stays the same.


Sincerely,

Tobi

Offline

#4 2014-10-29 11:46:21

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Re: Problem with COMB_SISM_MODAL

Hello again,

is there any way to avoid the bug?

Is it possible to calculate the stresses and forces by the displacements, which are calculated in COMB_SISM_MODAL?


Tobi

Offline

#5 2014-10-29 17:07:11

HBA
Member
Registered: 2014-06-05
Posts: 52

Re: Problem with COMB_SISM_MODAL

Hi,
I think you forgot to calculate the REAC_NODA in MODES after the MODE_ITER_SIMULT.
You can do so with a CALC_CHAMP.
There, you'll see an example where i calculate the REAC_NODA, SIEF_ELGA and EFGE_ELNO :

MODES=CALC_CHAMP(reuse =MODES,
                 RESULTAT=MODES,
                 EXCIT = _F(CHARGE = CHAR,),
                 PRECISION=1.E-08,
                 CONTRAINTE=(
			      'SIEF_ELGA',
			      'EFGE_ELNO',
			      ),
                 FORCE='REAC_NODA',);

Offline

#6 2014-10-30 10:38:18

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Re: Problem with COMB_SISM_MODAL

Hi,

thank you for your help. Did you calculated the REAC_NODA, SIEF_ELGA and EFGE_ELNO with my model?

When i calculate it i get this message:

La récupération des chargements concernant le résultat MODES n'est actuellement pas possible.
 Code_Aster ne peut donc pas vérifier la cohérence des chargements.

 Conseil : Si vous utilisez une commande avec une option qui nécessite la redéfinition des chargements,
 il faut vérifier la cohérence des chargements.

and the results looks really strange. See attached a pic of the result.

Can u send me the files of your example?


Tobi

Last edited by Tobvoll (2014-10-30 10:40:08)


Attachments:
SIEF_ELGA.bmp, Size: 1.43 MiB, Downloads: 372

Offline

#7 2014-10-30 15:55:53

HBA
Member
Registered: 2014-06-05
Posts: 52

Re: Problem with COMB_SISM_MODAL

No i didn't calculate your model, but that message is normal, it's not an error, Thomas DeSoza explained it in a topic :

Thomas DE SOZA wrote:

The second warning is a real warning, the calculation may proceed nonetheless : we can't verify that the loadings you provided were the exact same as the one you used for the calculation. But at least you were warned and with copy & paste, errors should be avoided.

Offline

#8 2014-11-20 15:37:30

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Re: Problem with COMB_SISM_MODAL

Hello,

i think to calculate the REAC_NODA in MODES after the MODE_ITER_SIMULT is not correct.

I use the Code_Aster Version 12.2 but the problem stays the same.

Is there nobody who knows how to avoid the bug?


Thanks in advance!

Tobi

Offline

#9 2014-11-20 15:51:57

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,622

Re: Problem with COMB_SISM_MODAL

hello

are you sure the calculation of reactions would have any meaning after a modal analysis?
i think not!

this is not Code_Aster it is physics

jean pierre aubry

Last edited by jeanpierreaubry (2014-11-20 15:52:54)


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#10 2014-11-20 16:12:30

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Re: Problem with COMB_SISM_MODAL

Hello Jean Pierre,

the calculation of reactions after a modal analysis have no meaning, that's right.

But i want to calculate the reactions after a response spectrum analysis with COMB_SISM_MODAL. And there I always get an error message (see above).
The calculation of the displacements works but i can't calculate any reaction.


Tobi

Offline

#11 2014-11-20 18:06:26

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,622

Re: Problem with COMB_SISM_MODAL

my advice
in COMB_SISM_MODAL drop the REAC_NODA from OPTION
then calculate REAC_NODA within a  CALC_CHAMP


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#12 2014-11-21 09:51:53

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,622

Re: Problem with COMB_SISM_MODAL

my previous suggestion does not work
it looks like there are largish discrepancies in between
COMB_SISM_MODAL command and its documentation U4.84.01
some keywords described in the doc are considered as unknown at runtime


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#13 2014-11-21 10:13:18

Tobvoll
Member
Registered: 2014-05-09
Posts: 13

Re: Problem with COMB_SISM_MODAL

Hello Jean Pierre,

thank you for your effort.

Am I right in assuming that there is currently no way to calculate the reactions after a response spectrum analysis with COMB_SISM_MODAL?


Sincerely,

Tobi

Offline

#14 2014-11-21 10:32:51

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,622

Re: Problem with COMB_SISM_MODAL

Tobvoll wrote:

Hello Jean Pierre,

thank you for your effort.

Am I right in assuming that there is currently no way to calculate the reactions after a response spectrum analysis with COMB_SISM_MODAL?


Sincerely,

Tobi

i am NOT qualified enough to certify that,
there may be a way unknown to me
i can only say that i meet the same troubles as you do meet

Last edited by jeanpierreaubry (2014-11-21 11:44:19)


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#15 2014-11-21 11:04:25

HBA
Member
Registered: 2014-06-05
Posts: 52

Re: Problem with COMB_SISM_MODAL

Hello,
You need to calculate the REAC_NODA in MODES as i said (if i'm right, comb_sism_modal only combines the modal results already calculated).

If your CALC_CHAMP-> REAC_NODA does not work it might be because an element can't be calculated.

Have you tried to use 'GROUP_MA' to do the calculation only on a simple element?

It's possible to calculate REAC_NODA with COMB_SISM_MODAL, i've done it many times with aster 11.6.

Offline