Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2022-03-05 12:07:18

jonas loenartz
Member
Registered: 2021-10-01
Posts: 51

issue (possible bug?) concerning POST_RELEVE_T

Hello everyone,

I have a question concerning the operator POST_RELEVE_T.

In a case I'm working on right now I defined 3D-faces, in order to use them with AFFE_CHAR_MECA --> FACE_IMPO.

I want to use POST_RELEVE_T to calculate the reaction-force of this constraint by using

sum_reac = POST_RELEVE_T(ACTION=_F(CRITERE='RELATIF',
                                   FORMAT_C='MODULE',
                                   GROUP_MA='f_spc',
                                   INTITULE='Summe Reaktionskräfte',
                                   MOYE_NOEUD='OUI',
                                   NOM_CHAM='REAC_NODA',
                                   OPERATION='EXTRACTION',
                                   PRECISION=1e-06,
                                   REPERE='GLOBAL',
                                   RESULTANTE=('DX', 'DY', 'DZ'),
                                   RESULTAT=stat,
                                   TOUT_ORDRE='OUI'),
                         INFO=1)

* This is the more verbose output of the command in the mess-file

I used this exact formulation lots of times, but with GROUP_NO instead of GROUP_MA.
Now I get the error-message:

 ╔════════════════════════════════════════════════════════════════════════════════════════════════╗
 ║ <EXCEPTION> <SUPERVIS_4>                                                                       ║
 ║                                                                                                ║
 ║ Erreur de syntaxe dans POST_RELEVE_T                                                           ║
 ║                                                                                                ║
 ║ At least one argument of ('GROUP_NO', 'NOEUD') must be defined                                 ║
 ║                                                                                                ║
 ║ Exception détaillée ci-dessous.                                                                ║
 ╚════════════════════════════════════════════════════════════════════════════════════════════════╝

I find this a little strange, because the documentation [U4.81.21] states at page 5, that you can use GROUP_MA to specify a list of mesh-groups, and that it can't be used in combination with GROUP_NO. I never had any problems with POST_RELEVE_T before, but this is the first time I tried using it with GROUP_MA.

Thanks in advance,
Jonas

Last edited by jonas loenartz (2022-03-06 15:24:21)

Offline