Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2022-01-18 10:06:02

Padr
Member
Registered: 2021-12-06
Posts: 29

[SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Hello everyone,

I am using Salome 2019 in Ubuntu 20.04.
I am initially having issues to post -process results from a simple triaxial (STAT_NON_LINE). I get the segmentation violation address 0.
Having read the forum that this might be due to graphics card, I installed an nvidia quadpro P400 and its driver, but still am getting the same issue.

Just a note, without the card I have been using the aster-study post processor with non linear static analysis normally (only elasticity) . The problem started since I introduced plasticity to the model.

Any ideas? I would appreciate any help.

Last edited by Padr (2022-03-03 09:44:25)

Offline

#2 2022-01-18 13:44:23

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 130

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Hi Padr,

Is it possible to share the result med file?

Offline

#3 2022-01-18 15:44:52

Padr
Member
Registered: 2021-12-06
Posts: 29

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Hello,

Med file attached. Am trying to simulate a 2D excavation of a gallery.

Merci d'avance.

Last edited by Padr (2022-01-18 16:52:44)


Attachments:
Mesh_1.med, Size: 37.23 KiB, Downloads: 91

Offline

#4 2022-01-18 16:55:24

Padr
Member
Registered: 2021-12-06
Posts: 29

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Here is also the rmed file of stage 2.
(Stage 1: set-up of initial stresses and Stage 2: excavation)


Attachments:
2D_excavationStage2.rmed, Size: 194.65 KiB, Downloads: 93

Offline

#5 2022-01-20 09:52:13

Padr
Member
Registered: 2021-12-06
Posts: 29

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Any ideas?

Still post - processing is crashing after I launch post-process in AsterStudy or Paravis.

Offline

#6 2022-01-20 19:34:58

k_zurawski
Member
From: Gdansk (Poland)
Registered: 2010-03-13
Posts: 172

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Have you tried installing libffi6_3.2.1-6_amd64.deb ?


regards,
Krzysztof

Offline

#7 2022-01-20 23:57:04

Padr
Member
Registered: 2021-12-06
Posts: 29

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

k_zurawski wrote:

Have you tried installing libffi6_3.2.1-6_amd64.deb ?

Yes I already installed it

Offline

#8 2022-01-31 09:23:13

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 130

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Hi Padr,

Sorry for the late response, I just got to test your result med file in salome_meca 2021 and I do not seem to get any error.

Attached hereby is a snapshot of the displacement magnitude field at the final instant.

Can you please try to install the 2021 version and tell us if you have the same issue ?

Regards,
HB


Attachments:
Capture d'écran de 2022-01-31 09-21-31.png, Size: 116.91 KiB, Downloads: 95

Offline

#9 2022-02-04 15:30:13

Padr
Member
Registered: 2021-12-06
Posts: 29

Re: [SOLVED] SIGSEGV "segmentation violation" - PLEASE HELP

Thank's a lot for your response.

Even though postprocess in Aster study is still not working, the only way I was able to postprocess my results is to open my results file immediately from Paravis via 'Open Paraview File' (note that 'Open in ParaVis' from Asterstudy is also not working).
Posting it just as a solution to post processing in case someone faces the same issue.

Currently I am using GMSH for post-processing.

Last edited by Padr (2022-03-03 09:46:56)

Offline