Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2021-03-27 21:31:35

Registered: 2019-10-04
Posts: 2

SM 2020 conflicting with Anaconda Python environment?


I'm doing a new install of Salome Meca on an updated machine with a clean install of Ubuntu 20.10. I installed Anaconda a while ago and I think this is the cause of my issues with SM.

I worked around the Python 3 vs Python 2 requirement using a Python 2 conda environment as detailed here:


But after installing (using the universal.run) I come up against the apparently common issue with "Asterstudy not found" because of a missing libffi.so.6 - which conda has in its python module library.

I tried to work around this problem by adding a symlink as in this post/thread:


But this didnt work either with the file unable to be found despite plainly being in the anaconda/lib folder.

It seems to me that the root of this issue is a mismatch between SM expecting a normal python environment and the previous installation of anaconda but I am not sure how to fix it.

Before diving into Sukumar's extravagant fix in the above thread, is there an easier way to get salome meca working?