Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-12-16 20:47:31

srouquette
Member
Registered: 2016-11-25
Posts: 23

[ SOLVED] PARAVIS not working / SalomeMeca2019 / Ubuntu18.04

Hello guys

I've just installed SalomeMeca 2019 on my computer under Ubuntu18.04.

I've used the sh procedure given in the download/install webpage of SM2019.

I opened SM2019 and started an easy thermal simulation: 3D rectangle, 100C on top face, 20C on bottom one and insulated on lateral ones.

I attached the files: hdf, .comm and med to this email as well as one screenshot of my problem (+install log file).

My problem: when i switch to PARAVIS... i can not able to open the .rmed. I've a message like "i've not saved tje study"... and if i click yes. i can just load the .hdf file.

My computer configuration:
ubuntu 18.04
python2 v2.17.17 (also python3 v3.6.7-1 but i use "update-alternatives" option to switch between 2 and 3)
gcc / g++ & gfortran v7.5.0
swig 3.0.12
bison 3.0.4
make 4.1
cmake 3.10.2
flex 2.6.4
grace 5.1.25
libopenblas-dev 0.2.20+ds-4
tk 8.6.0+9
zlib1g-dev 1.2.11dfgs

The install went well, it seemed to me... but i've a problem with PARAVIS. I ran the same simulation on a laptop fitted with SM2019 under 20.04 and i was able to visualize the result... the difference between the two computers is small... gcc/g++ / gfortran are 9.3.0 and swig is 4.0.1 are differents ...

I also tried the commande: salome -m PARAVIS ... and it is not working as well! i can't load the rmed... just the .hdf file???

I also noticed this message in my terminal: SalomeApp_Engine_i::Load() isMultiFile = 0 (when i activated PARAVIS)

Someone has an idea of this problem?

Thanks and best wished for the new year

PS: in my compressed folder: .hdf file, .comm file, .med file, .log file of SM2019 install, screenshot of SM2019 when PARAVIS is lauched.

Last edited by srouquette (2021-01-14 14:56:59)


Attachments:
box_thermal_case.zip, Size: 500.96 KiB, Downloads: 139

Offline

#2 2020-12-20 09:38:49

srouquette
Member
Registered: 2016-11-25
Posts: 23

Re: [ SOLVED] PARAVIS not working / SalomeMeca2019 / Ubuntu18.04

hello folks

i've "partially" or totally solved my problem.

I found a trick on the forum of salome-platform.org (post 498189789).

It is said:
"Try to clean the configuration files of Salome-Meca to start like it was the first installation on your computer. For Salome, the folder to remove is ~/.config/salome. It may have been customized for Salome-Meca in another folder."

I deleted this salome folder where i had multiple old stuff of salome-meca.

I can open PARAVIS... i still have a wrong message when i want to open the rmed file but if i go to the "paravis" main menu and click on "file/open paraview file" i am able to select and open .rmed !!!

let's see how it works in the future.

Regards
Sebastien

Last edited by srouquette (2020-12-20 09:39:47)

Offline

#3 2020-12-20 09:41:20

srouquette
Member
Registered: 2016-11-25
Posts: 23

Re: [ SOLVED] PARAVIS not working / SalomeMeca2019 / Ubuntu18.04

i don't understand how to classify this post as "SOLVED"???

Offline