Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-11-09 23:38:16

mf
Member
Registered: 2019-06-18
Posts: 239

[SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello,

will the upcoming 2020 version be installable on Ubuntu 20.04 LTS? Considering some of the posts in this forum there seem to be some problems with SM 2019 on 20.04.

Thank you,

Mario.

Last edited by mf (2021-02-10 21:00:55)

Offline

#2 2020-11-13 12:31:45

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hi,

is there an answer please? 'Yes' or 'no' is sufficient. I am sure that I am not the only one, who has to plan ahead,

thank you,

Mario.

Offline

#3 2020-11-13 15:51:08

GPSalachs
Member
Registered: 2018-03-10
Posts: 244

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello, this is out of the tip of my head after seeing the latest installation of code_aster .
I believe it will be possible to install it on the 20.04 version of Ubuntu but with the latest configurations on the packages
that are required. Now if the packages remain the same as the 2019 version then updating them into the latest won't be much of a problem.
I do not know about the python version >3.5 (?) ,but i believe that when the version comes out, it will be accompanied by the guides to install.

Offline

#4 2020-11-19 08:37:41

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello,

thank you, but I was hoping for an official answer by the developers. I cannot update our systems to 20.04 with the problems in mind, that other users had with with SM 2019 on 20.04. These systems must run '100%' error free. I cannot fiddle around for days to sort out any errors. I might not be able to correct upcoming errors myself!

Mario.

Offline

#5 2021-02-02 07:41:35

Bruno Zilli
Member
Registered: 2011-06-08
Posts: 12

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello

I managed to install samome-meca 2019 on ubuntu 20.04, by the following steps.

1-sudo apt install python
2-download and install libffi6_3.2.1-9_amd64.deb
3-./create_appli.sh
4-ln -s /usr/lib/x86_64-linux-gnu/libffi.so.6 libffi.so.6
5-mv libstdc++.so _libstdc++.so
6-mv libstdc++.so.6 _libstdc++.so.6
7-mv libstdc++.so.6.0 _libstdc++.so.6.0
8-mv libstdc++.so.6.0.22 _libstdc++.so.6.0.22

In this way, 2019 version is working with Aster Study correctly.

Salome-meca 2020 on ubuntu 20.04: I'm still struggling to get Aster Study working.

Bruno

Offline

#6 2021-02-02 14:09:20

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello Bruno,

thanks for the info. I am also trying SM 2020 on Ubuntu 20.04 LTS.

My calculation runs until the end, writes the results as expected without errors. Then SM throws an 'unexpected error'. When I save my Study after that and reopen it, my Stage in AsterStudy is GONE! I am sure this unexpected error (shouldn't all errors be unexpected??) is in the GUI.

Mario.

Last edited by mf (2021-02-02 14:09:32)

Offline

#7 2021-02-02 19:14:09

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello again,

I have to add to the above post:

-) The system was upgraded from Ubuntu 18.04 to 20.04, I did not do a fresh install of 20.04. That was never a problem.
-) I had a working SM2019 on this system before (I continued to use the SM installation that I did on 18.04 and upgraded to 20.04, no problem there).
-) I just did the usual install of SM2020. I did not do anything else.

Thus my question is: is there anything I have to upgrade regarding the prerequisites? There is no information on the download page. All information on the download page is quite old now.

Mario.

Offline

#8 2021-02-04 08:27:31

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Good morning,

I would very much appreciate a feedback to my questions. Is there anything I have to install additionally when installing SM 2020 on Ubuntu 20.04? I cannot be the only user worldwide with this configuration.

Thanks,

Mario.

Offline

#9 2021-02-08 18:17:08

Jcm
Member
Registered: 2019-09-28
Posts: 11

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hi Mario,

I have the same configuration. I tried to install SM 2020 on Ubuntu 20.04.2 LTS, everything appears to be fine, but, as I wrote in another post, in the geometry module when I try to use the commands "2D sketch, 3D sketch, Isoline, Create 2D Polyline" a message error appears:

GUI library corresponding to the user action can not be found or loaded

I don't know if there is something wrong in my installation procedure or there is some bugs in this release. Nobody replied me up to now.

Claudio

Offline

#10 2021-02-08 22:43:40

AsterO'dactyle
Administrator
Registered: 2007-11-29
Posts: 382

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?


Code_Asterの開発者

Offline

#11 2021-02-09 19:18:34

AsterO'dactyle
Administrator
Registered: 2007-11-29
Posts: 382

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello,

I've found something

Try to install packaqge libjpeg62 on your machine.


Code_Asterの開発者

Offline

#12 2021-02-10 08:38:53

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Hello,

thank you for your suggestions. Unfortunately, I can not test this until the weekend. I will report my findings then,

Mario.

Offline

#13 2021-02-10 20:57:59

mf
Member
Registered: 2019-06-18
Posts: 239

Re: [SOLVED] Salome Meca 2020 on Ubuntu 20.04 LTS?

Good evening,

I couldn't wait until the weekend, so I tried to solve it this evening. I am happy to report a success, at least a temporary success, you never know...

Basically, I took more care than last time and paid attention to every warning. Here is what I did:
1) I removed the former installation of SM (just deleted the folder)
2) I repeated the installation of SM 2020 with executing './salome_meca-2020.0.1-1-universal.run'
    Please find the output of this installation in the attached file '1.installation.txt'
    RESULT of this 1. installation was basically:
    '.... ./create_appli.sh: Zeile 271: python: Befehl nicht gefunden'      it is a 'file not found error'
    Thus I executed: 'sudo apt install python'
    This old python command is in package 'python-is-python2 (2.7.17-4)'. I assume it is because python3 is standard on
    Ubuntu 20.04LTS.
3) I removed the installation from 1) again, just deleted the folder.
4) I did a reinstall of './salome_meca-2020.0.1-1-universal.run'.
     Please find the output of this installation in the attached file '2.installation.txt'
     RESULT of this installation was another error:
     '..../create_appli.sh: Zeile 301: Syntaxfehler beim unerwarteten Wort »fi«
      ./create_appli.sh: Zeile 301: `fi' '
     So this is a syntax error in execution of 'create_appli.sh'. I looked at line 301 in 'create_appli.sh' I did not find anything
     suspicious. But beware: I am not a great programmer.
5) I decided to ignore this error and start SM 2020 with an old example done on SM 2019 (CA 14.4). Of course it would complain about the old version of CA, but this is to be expected.
6) The example executed without error, also I did not get the error from SM GUI mentioned above.

So for now, I am satisfied and will mark this solved. It was a small basic error.

So, basically you need to install the old 'python' command also on Ubuntu 20.04 LTS. Let's hope this is all there is.

@Jcm: is your problem solved with the posts of AsterO'dactyle?

Please find attached the output texts of both installations. It may be relevant for anyone with the same basic setup.

Mario.

Last edited by mf (2021-02-10 20:59:58)


Attachments:
output files after installation.zip, Size: 1.85 KiB, Downloads: 166

Offline