Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-12-20 19:37:04

GXA_William
Member
Registered: 2016-04-30
Posts: 44

Salome_Meca V2019.0.3_Ubuntu 16.04 Installation Issues

Greetings Forum.

We cannot find a successful method for getting the last two version of SMECA to install and run on 16.04 (both V2019.0.1-2 and V2019.0.3 fail).  We have tried all of the tricks which worked for V2019.0.1-1 - but none resolve the issue.

Has anyone else encountered the same issue and (hopefully) solved it?  See below for copy/paste of the error codes.

My guess is that the errors relate to newer versions of Python and QT which perhaps do not play well with 16.04.  Short of upgrading to 18.04 (and causing numerous incompatibility issues with other SW installs) we are stumped.

Any hints are appreciated.

-William

-------------------------------------------------------------------------
Searching for a free port for naming service: 2816 - OK
Searching Naming Service  + found in 0.1 seconds
Searching /Kernel/Session in Naming Service  +SALOME_Session_Server: symbol lookup error: /opt/V2019.0.3_universal/prerequisites/debianForSalome/lib/libOpenGL.so.0: undefined symbol: _glapi_tls_Current
Traceback (most recent call last):
  File "/opt/V2019.0.3_universal/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 172, in waitNSPID
    os.kill(thePID,0)
ProcessLookupError: [Errno 3] No such process

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/opt/appli_V2019.0.3_universal/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/opt/appli_V2019.0.3_universal/bin/salome/runSalome.py", line 578, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/opt/V2019.0.3_universal/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError("Process %d for %s not found" % (thePID,theName))
RuntimeError: Process 19315 for /Kernel/Session not found

-------------------------------------------------------------------

Offline

#2 2020-03-06 19:11:10

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 30

Re: Salome_Meca V2019.0.3_Ubuntu 16.04 Installation Issues

Hi there,

Can you elaborate further on the target system for the installation ? Is it a physical OS or a virtual one ?

GL problems are often encountered if the graphics card is not available (like from within a virtual machine). Can you try to launch  glxinfo and share the output?

HB

Offline