Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-05-15 08:24:17

Registered: 2014-09-16
Posts: 21

Salome-Meca V2018 on Ubuntu 18.04

There are questions similar to mine on the forum, but none of the answers seem to solve my problems.

As background, I have had SM 2018, and probably two or three previous versions,  installed on Ubuntu 16.04. I upgraded Ubuntu 18.04 and everything worked fine.

After a disk crash I did a fresh install of Ubuntu 18.04 and SM 2018.

To Install SM, I had to install Python 2.7 and had to unzip the archive with 7zip as gzip corrupted the run file. (This may be of value to somebody)

I now have SM 2018 and SM 2017.0.2 installed and I have the same problems on both:
-Starting AsterStudy from SM gives me the message "Failed to activate module AsterStudy"
-The help files do not open from the Help menu. (The path to my browser is correctly specified  in  Preferences)
-Preferences are not saved, it opens with the defaults every time.
-Every time SM is opened the "Most recently used" file list is empty.

I can live with the last three, but I include them in case the problems are related.

My last possible clue, if I start SM from the terminal I get:
Error when trying to access active network connections.
Traceback (most recent call last):
  File "/home/johan/SM_2018/appli_V2018.0.1_public/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort
    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)
  File "/home/johan/SM_2018/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/home/johan/SM_2018/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Searching for a free port for naming service: 2810 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service ++Gtk-Message: 09:16:39.842: Failed to load module "canberra-gtk-module"
Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.

Your help is appreciated. Thank you in advance


#2 2019-05-15 08:33:36

Registered: 2018-03-10
Posts: 261

Re: Salome-Meca V2018 on Ubuntu 18.04


as far as the first problem arises i think i have seen a workaround in the forum. Did you install Salome as root? I have had the same problem due to a root install i have once made. It did correct itself once i installed it as regular user.
I don't know if it can be of help but have a look at this thread: https:/_/code-aster.org/forum2/viewtopic.php?pid=57106#p57106


#3 2019-05-15 10:49:52

Registered: 2014-09-16
Posts: 21

Re: Salome-Meca V2018 on Ubuntu 18.04

Thanks for the prompt response.

It is not installed as root and moving the files as in the link did not help. Unfortunately I do not know how to reinstall the libxx files in Ubuntu.


#4 2019-06-30 09:46:07

From: France
Registered: 2007-11-21
Posts: 1,183

Re: Salome-Meca V2018 on Ubuntu 18.04

You could try with a new user account to check if it is related to your user environment.

Preferences, most recently used files...: $HOME/.config/salome directory may be corrupted. You can remove it (you only loose some prefs).

Code_Aster release : last unstable on Ubuntu 16.04 64 bits - GNU Compilers

Please do not forget to tag your first post as *SOLVED* when it is!


#5 2019-07-01 10:35:04

From: Chemnitz
Registered: 2016-05-23
Posts: 92

Re: Salome-Meca V2018 on Ubuntu 18.04

I was the next one with this problem.
On my machine helps this, and I don't know why:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' ./salome
(see thread code-aster.org/forum2/viewtopic.php?id=24078)

Last edited by Volker (2019-07-01 10:36:33)