Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2018-07-16 17:43:35

Registered: 2017-11-19
Posts: 28

[solved] Salome-Meca 2018 running error Fedora 27 libstdc++


I've just installed Salome-Meca 2018. I can't wait to play with this new version. Unfortunaly, i get the following error at launch, when salome-meca 2017 was running good.


runSalome running on localhost.localdomain
Searching for a free port for naming service: 2817 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service +SALOME_Session_Server: /home/joalland/salome_meca/V2018/prerequisites/debianForSalome/lib/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /lib64/libGLU.so.1)
Traceback (most recent call last):
  File "/home/joalland/salome_meca/appli_V2018/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/joalland/salome_meca/appli_V2018/bin/salome/runSalome.py", line 578, in startSalome
  File "/home/joalland/salome_meca/V2018/modules/KERNEL_V8_5_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 5147 for /Kernel/Session not found

I don't get what is my issue with the libstdc++.so.6 packed in the binary.

Could any one help ? Thanks.

Last edited by Voulet (2018-07-24 18:14:53)


#2 2018-07-23 16:48:48

Thomas DE SOZA
From: EDF
Registered: 2007-11-23
Posts: 3,066

Re: [solved] Salome-Meca 2018 running error Fedora 27 libstdc++


Thank you for reporting that.
Please try the following:

1. move the files below out of their directory

mkdir -p $HOME/tmp 
mv /home/joalland/salome_meca/V2018/prerequisites/debianForSalome/lib/libstdc++.*  $HOME/tmp

If it does not solve the error, please continue.

2. follow the instructions for the Red Hat 7 derivatives given on the download page: https://www.code-aster.org/V2/spip.php?article303

This install another libstdc++ library that may solve the problem.

If it still does not work, please report here about the various errors.



#3 2018-07-24 18:14:18

Registered: 2017-11-19
Posts: 28

Re: [solved] Salome-Meca 2018 running error Fedora 27 libstdc++

Thanks for your answer Thomas,

The first step solved the issue. I didn't have to follow the second step.