Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2010-06-29 16:25:19

JMB365
Member
Registered: 2008-01-19
Posts: 781

[SOLVED] Using Homard 9.6 with 10.2

Hello,

I am trying Homard for the first time, and my knowledge of its syntax is poor.  I have installed Homard 9.6, since I began running Ver 10.2.  After the first round in CodeAster STAT_NON_LINE solver I am getting an error in Homard:

Nombre de tableaux        :       40
Le pas de temps d'interpolation n'a pas ete choisi.
Sortie du sous-programme ESLCH2
Probleme : code retour =     1

i.e.

Number of tables: 40
The time step interpolation has not been chosen.
Exit subroutine ESLCH2
Problem: return code = 1

My Homard command is:

   MACR_ADAP_MAIL(QUALITE='OUI',
                 INFO=1,
                 INDICATEUR='ERRE_ELEM_SIGM',
                 NOM_CMP_INDICA='ERREST',
                 RESULTAT_N=Sol,
                 MAILLAGE_NP1=CO('Mesh1'),
                 INTERPENETRATION='NON',
                 LANGUE='FRANCAIS',
                 TAILLE='OUI',
                 TYPE_OPER_INDICA='MAILLE',
                 TYPE_VALEUR_INDICA='V_ABSOLUE',
                 PROP_CALCUL='NON',
                 ADAPTATION='RAFFINEMENT',
                 NOMBRE='OUI',
                 MAILLAGE_N=Mesh,
                 CONNEXITE='OUI',
                 ELEMENTS_NON_HOMARD='REFUSER',
                 CRIT_RAFF_PE=0.29999999999999999,
                 VERSION_HOMARD='V9_6',
                 );

 Code retour = 2560      (maximum toléré : 0)

Where Mesh is the unrefined mesh, Sol is its final solution after 40 time steps, and Mesh1 is supposed be the new refined mesh.  It is supposed to refine 30% of the mesh (Thanks to clarification by Nicolas and he advises it is too much at once) based on the ERREST (Estimated Error - my guess) of ERRE_ELEM_SIGM.

Can somebody shed some light on my problem please, since one handicap at the moment is my Eficas catalogue is current only upto to 10.1 (not yet at 10.2) and piloting the command structure is therefore absent.  I suppose reading / understanding the documentation will help, but any assistance would be very much appreciated!  Thank you.

Regards,
JMB

PS: The *.mess file is attached...

Last edited by JMB365 (2010-07-07 19:06:16)


SalomeMeca 2021
Ubuntu 20.04, 22.04

Offline

#2 2010-06-29 17:03:20

Nicolas
Member
From: EDF Lab Saclay
Registered: 2007-11-29
Posts: 98

Re: [SOLVED] Using Homard 9.6 with 10.2

Hello,
In your command, you asked for a refinement according to the field ERRE_ELEM_SIGM. But this field is available for every time step (see the command CALC_ELEM). So you must precise which time step is required: add the key-word NUME_ORDRE=xxx in MACR_ADAP_MAIL.

Some comments:
1. This error indicator is only valid for linear calculation. In non linear problems, there is no guarantee for the result (see R4.10.02); you could use a simpler indicator known as 'Zhu-Zinkiewicz' (see R4.10.01).
2. The value 30% does not mean that the element size would be reduced by 30%. The signification is the followings: the tetrahedrons are sorted according the level of the estimated error and the worst 30% will be refined. So such a threshold is quite high. You'd better try with a few %. If not, your mesh will be quickly uniformly refined.
3. I suggest that you use the command MACR_INFO_MAIL, with all the options, on the inital mesh. That will give you a diagnosis on your mesh: quality, holes, overlapping,... Then, only use those options in MACR_ADAP_MAIl if there is a problem.
4. Try english: LANGUE='ENGLISH'
5. Last, you should read the documentation even if it is in french ! For the syntax of the commands: U7.03.01 and U7.03.02. For a general overview on mesh adaptation, U2.08.01.


Gérald NICOLAS
EDF R&D
Responsable du logiciel HOMARD

Offline

#3 2010-06-29 18:00:05

JMB365
Member
Registered: 2008-01-19
Posts: 781

Re: [SOLVED] Using Homard 9.6 with 10.2

Nicolas wrote:

Hello,
In your command, you asked for a refinement according to the field ERRE_ELEM_SIGM. But this field is available for every time step (see the command CALC_ELEM). So you must precise (specify) which time step is required: add the key-word NUME_ORDRE=xxx in MACR_ADAP_MAIL.

I had assumed that Homard would use the last time step to refine the mesh.  Now I realize that a user can specify any suitable and intermediate time step.

Nicolas wrote:

Some comments:
1. This error indicator is only valid for linear calculation. In non linear problems, there is no guarantee for the result (see R4.10.02); you could use a simpler indicator known as 'Zhu-Zinkiewicz' (see R4.10.01).
2. The value 30% does not mean that the element size would be reduced by 30%. The significance is the following: the tetrahedrons are sorted according the level of the estimated error and the worst 30% will be refined. So such a 30% threshold is quite high. You'd better try with a few %. If not, your mesh will be quickly uniformly refined.
3. I suggest that you use the command MACR_INFO_MAIL, with all the options, on the initial mesh. That will give you a diagnosis on your mesh: quality, holes, overlapping,... Then, only use those options in MACR_ADAP_MAIL if there is a problem.
4. Try english: LANGUE='ENGLISH'
5. Last, you should read the documentation even if it is in french ! For the syntax of the commands: U7.03.01 and U7.03.02. For a general overview on mesh adaptation, U2.08.01.

Thank you for your direction and advice.  I do intend reading the Docs, but sometimes a short explanation like yours makes a huge difference in one's journey on a learning curve.  Thank you.

Regards,
JMB


SalomeMeca 2021
Ubuntu 20.04, 22.04

Offline