Welcome to the forums. Please post in English or French.

You are not logged in.

#1 Re: Salome-Meca installation » Using Salome-Meca on Ubuntu 20.04 WSL 2 » 2021-06-04 20:21:16

Hey, sorry for not updating the question. The solution I came up was to install Ubuntu 18.04 and use the script that is provided by Code Aster to install Salome Meca in virtual machines. You can find my version of the script in my github repo.
github.com/PeterMoresco/auto_free_fea_sim/tree/main/installing_sm

#2 Salome-Meca installation » Using Salome-Meca on Ubuntu 20.04 WSL 2 » 2021-04-15 15:11:00

Pedro_Moresco
Replies: 2

Hey everyone, I'm installed SM 2020 and 2019 on a WSL Ubuntu 20.04, I'm trying to generate some geometries and meshes with this command:

./salome -t geom.py

and I'm getting this error:

'''
th. 140279767300992 - Trace /home/A21173/smeca/yamm_build/V2019.0.3_pub_build/V2019_universal/modules/src/KERNEL/src/ModuleCatalog/SALOME_ModuleCatalog_Server.cxx [101] : Module Catalog Server: Naming Service was found
Warning: this type (Study,objref) already exists, it will be ignored.
Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.
Component GEOM: C++ implementation found /home/pedro/salome_meca/appli_V2019.0.3_universal/lib/salome/libGEOMEngine.so but it is not loadable. Error:
libGLU.so.1: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/home/pedro/Documents/testSalome/tambor.py", line 50, in <module>
    geompy = geomBuilder.New()
  File "/home/pedro/salome_meca/appli_V2019.0.3_universal/lib/python3.6/site-packages/salome/salome/geom/geomBuilder.py", line 14091, in New
    assert isinstance(geom,geomBuilder), "Geom engine class is %s but should be geomBuilder.geomBuilder. Import geomBuilder before creating the instance."%geom.__class__
AssertionError: Geom engine class is <class 'NoneType'> but should be geomBuilder.geomBuilder. Import geomBuilder before creating the instance.
ERROR:salomeContext:SystemExit 1 in method _runAppli.
'''

So I've searched in the forums and I'm not quite sure about what happened. If u could help me I'll be glad.
The two files needed to run the command are attached.

#3 Re: Salome-Meca usage » how to launch salome (win x64) in python? » 2020-09-05 17:24:16

Hi, I know this is a little silly, but are you using Power Shell? Because I cannot run my .bat scripts in power shell.
Try run your launch script as an administrator and post here the error you get by doing so.
By my experience, the windows port work just fine and effortlessly.

#4 Salome-Meca usage » ParaVis error malloc(): invalid size(unsuported) » 2020-09-04 17:17:53

Pedro_Moresco
Replies: 1

Hi, I installed Salome-Meca 2019 in a fresh installed KDE Neon( base Ubuntu 20).
After the simulation is done in the AsterStudy, if I go to the Paravis module and load the 'SIEF_ELGA', 'SIEF_ELNOEU' and 'SIEF_ELNO' it crashes and I get the message:

malloc(): invalid size (unsorted)

And I don't know if this is related, everytime I get this message when starting Salome-Meca:
+****************************************************************
     Warning: module NETGENPLUGIN is improperly configured!
     Module NETGENPLUGIN will not be available in GUI mode!
****************************************************************
****************************************************************
     Warning: module HYBRIDPLUGIN is improperly configured!
     Module HYBRIDPLUGIN will not be available in GUI mode!
****************************************************************
****************************************************************
     Warning: module HexoticPLUGIN is improperly configured!
     Module HexoticPLUGIN will not be available in GUI mode!
****************************************************************
****************************************************************
     Warning: module GHS3DPLUGIN is improperly configured!
     Module GHS3DPLUGIN will not be available in GUI mode!
****************************************************************
****************************************************************
     Warning: module BLSURFPLUGIN is improperly configured!
     Module BLSURFPLUGIN will not be available in GUI mode!
****************************************************************
****************************************************************
     Warning: module GMSHPLUGIN is improperly configured!
     Module GMSHPLUGIN will not be available in GUI mode!
****************************************************************

#5 Introduce yourself / Présentez vous » Hello from Brazil! » 2018-08-07 21:15:50

Pedro_Moresco
Replies: 0

Hello friends! I'm about to become a mechanical engineer and I'm starting in FEA and a friend recommend me code_aster/Salome-Meca, I will try to help everyone I can! See ya!