Welcome to the forums. Please post in English or French.

You are not logged in.

#1 Salome-Meca installation » Salome Meca for Windows » 2021-02-02 07:09:10

blckwtr
Replies: 0

I cannot run the test case properly, giving output --- DIAGNOSTIC JOB : <A>_ALARM

I have provided the script from command prompt in hope someone can help me fix this...

Best regards

Tommy

#2 Salome-Meca installation » error launching salome-meca after install » 2019-05-15 04:48:44

blckwtr
Replies: 1

runSalome running on blckwtr-Latitude-E6410
INFO:MainThread:Problem loading PortManager file: /tmp/.salome_PortManager.cfg
INFO:PortManager:Problem loading PortManager file: /tmp/.salome_PortManager.cfg
Error when trying to access active network connections.
Traceback (most recent call last):
  File "/home/blckwtr/salome_meca/appli_V2018.0.1_public/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort
    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)
  File "/home/blckwtr/salome_meca/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/home/blckwtr/salome_meca/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Searching for a free port for naming service: 2810 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service ++++
(SALOME_Session_Server:27997): Gtk-WARNING **: 05:44:58.286: Unable to locate theme engine in module_path: "adwaita",

(SALOME_Session_Server:27997): Gtk-WARNING **: 05:44:58.296: Unable to locate theme engine in module_path: "adwaita",
+libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
+libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.
+Traceback (most recent call last):
  File "/home/blckwtr/salome_meca/appli_V2018.0.1_public/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/blckwtr/salome_meca/appli_V2018.0.1_public/bin/salome/runSalome.py", line 578, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/blckwtr/salome_meca/V2018.0.1_public/modules/KERNEL_V8_5_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 27997 for /Kernel/Session not found


--- Error during Salome launch ---

#3 Salome-Meca installation » SOLVED: salome_meca installed in french ? » 2017-11-02 23:04:16

blckwtr
Replies: 0

I did this, and the installation is in french

Enter the salome_meca install directory [default=/home/blckwtr/salome_meca] :
The directory /home/blckwtr/salome_meca/V2017 already exists, install anyway ? [y/N] y
salome_meca is in English, do you want to be in French ? [y/N] : n
Installation of salome_meca V2017 in /home/blckwtr/salome_meca/V2017 ...

How can I reinstall, if I at a previously time by accident said y to that question ?

EDIT: I could change language from menu, I wasn't aware of this...

#4 Re: Salome-Meca installation » SOLVED: Problems installing Salome-Meca on Kubuntu » 2017-11-02 23:01:28

Thanks, I thought the installation had stopped, but it did actually install just fine. However, the installation is in french, although I clearly remember saying no to that question... How can I reinstall in english? I have tried to run the install again, but still in french...

EDIT: Both the installation and the language is fine, I can change the language from menu...

#5 Salome-Meca installation » SOLVED: Problems installing Salome-Meca on Kubuntu » 2017-11-01 18:54:32

blckwtr
Replies: 2

I get this during installation, every prerequisites is already installed...

blckwtr@blckwtr-Lenovo-B560:~/Downloads$ ./Salome-Meca-2017.0.1-LGPL-1.run

===========================================
Self Extracting salome_meca V2017 Installer
===========================================

Enter the salome_meca install directory [default=/home/blckwtr/salome_meca] :
The directory /home/blckwtr/salome_meca/V2017 already exists, install anyway ? [y/N] y
salome_meca is in English, do you want to be in French ? [y/N] : n
Installation of salome_meca V2017 in /home/blckwtr/salome_meca/V2017 ...
Verifying archive integrity...
All good.
Done                                                                                           
Creating salome_meca application in /home/blckwtr/salome_meca/appli_V2017 ...
chmod: cannot access '/home/blckwtr/.local/share/applications/salome_meca_V2017.desktop': No such file or directory
chmod: cannot access '/home/blckwtr/Desktop/salome_meca_V2017.desktop': No such file or directory
salome_meca post-installation ...
Adjusting the file : /home/blckwtr/salome_meca/appli_V2017/SalomeApp.xml
Warning: the directory /home/blckwtr/bin is in a path variable but does not exist
Warning: the directory /home/blckwtr/.local/bin is in a path variable but does not exist
Warning: the directory /snap/bin is in a path variable but does not exist

#7 Re: Salome-Meca installation » Unable to launch salome_meca after install OpenSUSE salome_meca_2016 » 2017-02-24 20:00:55

I have tried both salome and salome-meca, they are not compatible... I have found another thread which say that you need to install using python virtual environment, since the installation utilizes an older version, 2.7.10, while this installed version have used 2.7.12... But I need a step by step recipe, since I am relatively new to linux...

#8 Re: Salome-Meca installation » Unable to launch salome_meca after install OpenSUSE salome_meca_2016 » 2017-02-23 12:39:29

I see that the installation requires python 2.7.10

But how actually do I proceed in order to install within this environment ?

#10 Salome-Meca installation » Unable to launch salome_meca after install OpenSUSE salome_meca_2016 » 2017-02-23 10:40:34

blckwtr
Replies: 10

I am unable to launch after install, I have tried following;

./salome
./runAppli

I have installed all prerequisites, i.e.
◾ gcc, g++, gfortran (or other compilers), installed only gcc
◾ cmake,
◾ python,
◾ python-dev,
◾ python-numpy,
◾ python-qt4,
◾ tk,
◾ bison,
◾ flex,
◾ liblapack-dev, libblas-dev ou libopenblas-dev,
◾ zlib (named zlib1g-dev on debian/ubuntu).

Got these messages after liblapack, libblas and libopenblas

blckwtr@linux-2d2z:~/Downloads> sudo apt-get install liblapack-dev
Loading repository data...
Reading installed packages...
'liblapack-devel' not found in package names. Trying capabilities.
No provider of 'liblapack-devel' found.
Resolving package dependencies...

Nothing to do.
blckwtr@linux-2d2z:~/Downloads> sudo apt-get install libblas-dev
Loading repository data...
Reading installed packages...
'libblas-devel' not found in package names. Trying capabilities.
No provider of 'libblas-devel' found.
Resolving package dependencies...

Nothing to do.
blckwtr@linux-2d2z:~/Downloads> sudo apt-get install libopenblas-dev
Loading repository data...
Reading installed packages...
'libopenblas-devel' not found in package names. Trying capabilities.
No provider of 'libopenblas-devel' found.
Resolving package dependencies...

Nothing to do.
blckwtr@linux-2d2z:~/Downloads>

After installed prerequisites, I install and launch program with these errors:


blckwtr@linux-2d2z:~/salome_meca/appli_V2016> ./salome
WARNING:salomeContext:Overwriting environment variable: PYTHONSTARTUP=/home/blckwtr/salome_meca/V2016/prerequisites/Python-2710/pythonrc.py                                                 
runSalome running on linux-2d2z                                                           
Searching for a free port for naming service: 2813 - OK                                   
Searching Naming Service ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++Failed to narrow the root naming context                           
Traceback (most recent call last):                                                             
  File "/home/blckwtr/salome_meca/appli_V2016/bin/salome/runSalome.py", line 620, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)                                     
  File "/home/blckwtr/salome_meca/appli_V2016/bin/salome/runSalome.py", line 417, in startSalome 
    clt=orbmodule.client(args)                                                                   
  File "/home/blckwtr/salome_meca/V2016/modules/KERNEL_V7_8_0/bin/salome/orbmodule.py", line 47, in __init__
    self.initNS(args or {})
  File "/home/blckwtr/salome_meca/V2016/modules/KERNEL_V7_8_0/bin/salome/orbmodule.py", line 86, in initNS
    sys.exit(1)
SystemExit: 1


--- Error during Salome launch ---
blckwtr@linux-2d2z:~/salome_meca/appli_V2016>