Welcome to the forums. Please post in English or French.

You are not logged in.

#1 Code_Aster installation » Parallel version using intel compiler » 2020-04-07 08:59:36

IV_CoAs
Replies: 0

Hello,

I tried to compile parallel version of CA 14.4. MUPS compiling was successful, but CA failed. I have attached log file. Terminal informs mpi.h problem.

I used following source command:
source /opt/intel/bin/compilervars.sh intel64 -platform linux
source /opt/intel/mkl/bin/mklvars.sh intel64

Checking for 'gcc' (C compiler)          : not found
Checking for 'clang' (C compiler)        : not found
Checking for 'icc' (C compiler)          : mpiicc
Checking for 'g++' (C++ compiler)        : mpicxx
Checking for 'gfortran' (Fortran compiler) : not found
Checking for 'g95' (Fortran compiler)    : not found
Checking for 'ifort' (Fortran compiler)  : mpiifort
Checking for ''                          : yes
Checking for ''                          : yes
Checking for header mpi.h                : not found

Using GNU compiler parallel version is successful, but comparing to Ansys solver, CA using GNU compiler is clearly slower than Ansys Sparse solver.

I hope, that somebody can help.

Best Regards
Ilkka

#2 Code_Aster usage » [SOLVED] Parallel contact analysis with MUMPS solver » 2019-11-28 09:03:33

IV_CoAs
Replies: 0

Hello,

I have problems with parallel MUMPS solver and contacts. I have attached med -file and command -file. Analysis don't go ahead after first iteration, while with MULT_FRONT solver I don't get any problems.

Question is, that have I failed MUMPS  compiling or is there some problems with contacts and MUMPS in parallel calculations in CA 14.4 ?

BR.
Ilkka

Problem was solved, when using Ubuntu 18.04 platform instead of Ubuntu 16.04 platform. Possible reason Python version 3.5 vs. 3.6 or other library related problem. (No time nor skills to find specific reason)

BR Ilkka

#3 Re: Salome-Meca usage » Bugs in Salome Meca 2019 » 2019-10-21 13:32:37

IV_CoAs wrote:

Hello,

In AsterStudy, when trying to add Element or mesh group second time (when pressing edit button), following error occurs:

"
Traceback:
File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/panel.py", line 632, in _gotoParameter
wid = self._createParameterView(path, link)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/panel.py", line 663, in _createParameterView
pview = ParameterMeshGroupWindow(path, self, self.views)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/windows.py", line 435, in __init__
parent_item=None, parent=self)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 1896, in __init__
self._updateMeshList()

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 2280, in _updateMeshList
self._meshActivated(self._mesh.currentIndex())

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 2304, in _meshActivated
self.setMeshGroups(groups)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 2006, in setMeshGroups
for name, size, occurs in names:

"

BR Ilkka

I find out, that this problem exist, when in "LIRE_MAILLAGE" is external med file used. If used mesh in same study, problem seems to be solved. (Salome-Meca Version 2019.0.1)

BR Ilkka

#4 Re: Salome-Meca usage » Bugs in Salome Meca 2019 » 2019-10-17 11:23:29

Hello,

In AsterStudy, when trying to add Element or mesh group second time (when pressing edit button), following error occurs:

"
Traceback:
File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/panel.py", line 632, in _gotoParameter
wid = self._createParameterView(path, link)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/panel.py", line 663, in _createParameterView
pview = ParameterMeshGroupWindow(path, self, self.views)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/windows.py", line 435, in __init__
parent_item=None, parent=self)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 1896, in __init__
self._updateMeshList()

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 2280, in _updateMeshList
self._meshActivated(self._mesh.currentIndex())

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 2304, in _meshActivated
self.setMeshGroups(groups)

File "/home/laskija/salome_meca/V2019_univ/modules/ASTERSTUDY_20190/lib/python3.6/site-packages/asterstudy/gui/parameterpanel/views.py", line 2006, in setMeshGroups
for name, size, occurs in names:

"

BR Ilkka

#5 Re: Salome-Meca installation » SalomeMeca2019 on Ubuntu 18.04 » 2019-10-12 15:02:22

Hello
”www.code-aster.org/V2/spip.php?article1076”

Follow this French speaking article. It has right instructions, maybe some parts should not be capital character, but apt-get install command will tell it.

Using these instructions my ubuntu 18.04 platform is working.

Br Ilkka

#6 Re: Code_Aster installation » [SOLVED] configuring MUMPS with waf » 2019-10-08 12:03:26

Hello,

I had similar problems with waf, but I manage to compile it using brutal "Kekkosen konsti", which means,that:

1. I copied MUPS-5.1.1 (Aster 13.6) Makefile.inc
2. Change all paths to new paths in this file
3. make all

I manage to make parallel (mpi) mumps using this method; naturally it is not good permanent solution and I hope that somebody can give solution for waf 'dvars' problem.

BR
Ilkka

#7 Code_Aster installation » [SOLVED] Aster 14.4 Parallel compiling » 2019-10-07 12:24:05

IV_CoAs
Replies: 0

Hello,

I have compiled Aster 14.4 full package sequential with success, but with parallel I faced problem, which didn't exist when compiling 13.6 parallel.

Below copy from terminal:

"
Checking measure of VmSize during MPI_Init : failed (memory consumption can not be estimated during the calculation)
Checking for library pthread             : yes
Checking for library dl                  : yes
Checking for library util                : yes
Checking for program 'python'            : /usr/bin/python3
Checking for python version >= 3.5.0     : 3.5.2
python-config                            : /usr/bin/python3-config
Asking python-config for pyembed '--cflags --libs --ldflags' flags : yes
Testing pyembed configuration            : yes
Asking python-config for pyext '--cflags --libs --ldflags' flags : yes
Testing pyext configuration              : yes
Checking for numpy                       : /usr/lib/python3/dist-packages/numpy/__init__.py
Checking for numpy version               : 1.11.0
Checking for numpy include               : ['/usr/lib/python3/dist-packages/numpy/core/include']
Checking for asrun                       : Could not find the python module 'asrun'

"

My attempts stops to this asrun module and my question is, how to add it to compiling process.

I did compiling from extracted Aster package, and it was succesfull with 13.6 version, but now it doesn't work
Command which I used to configure waf:
./waf configure --enable-mpi --enable-openmp --enable-med --enable-hdf5 --
enable-mumps --embed-mumps --enable-petsc --embed-petsc --use-config=iva --maths-libs=auto  --enable-metis --embed-metis --prefix=$ASTER_ROOT/PAR14.4 --use-config-dir=/$ASTER_ROOT/14.4/share/aster

I have attached also log file. I hope, that somebody can help in this matter.

BR
Ilkka

Adding to console before configuring following:
"
export PYTHONPATH=/$ASTER_ROOT/lib/python3.5/site-packages/:$PYTHONPATH
"
solve the problem.

BR
Ilkka

#8 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-07 06:32:23

Hello,

Thanks GXA_William, Wintermute and others.

I confirm, that
"
(from the salome_meca/appli_v2019/ folder)

source /env.d/envProducts.sh
./salome
"
solved this problem. I am not specialist in IT, but I guess, that my Qt 5.9.1 installation was not totally successful and make problems, but  with above method using console it was working.

I will mark this topic as solved.

MR Ilkka

#9 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-04 07:10:27

GXA_William wrote:

Hello Ilkka.

Another suggestion:

Open a terminal and paste the following: source /opt/appli_V2019_univ/env.d/envProducts.sh

Then in the same terminal paste: /opt/appli_V2019_univ/salome

Does it run now?

-William

Hello,

didn't help. Then I tried to use instruction in French language news for ubuntu 18.04 (libstdc++) and result is in atttached file. It is saying about libprotubuf version, but according dpkg  list I have high enough version of libprotobuf.

BR Ilkka

#10 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-03 14:36:50

GXA_William wrote:

Hello Ilkka.

Check if your system has libnlopt.so.0 and libnlopt.so.0.8.2 files in your /usr/lib/x86_64-linux-gnu folder.  That is where I see those files on our machine.

There is a suggestion in an earlier post from Dezsit to include export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu:$LD_LIBRARY_PATH.  I did not have to explicitly generate this link before running SMECA, but perhaps it will help you?...worth a try.

Hello Mathieu.

As a follow up, even though SMECA issues the "Warnings" about GMESH, HYBRID and BLSURF plugins, the Mesh module allows for one to select any of the MeshGems products (CadSurf, Hybrid, Tetra, etc.) and also Gmsh - so it seems these warnings can be ignored.

Still the desktop icon is not launching SMECA v2019; will look more into that sometime today.

-William

Hello,
They were in place, which You rote. I tried also this /usr/lib/x86_64-linux-gnu, but didn't help.

BR Ilkka

#11 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-03 08:31:40

Hello,

Unfortunately my Ubuntu 16.04 platform didn't work using above. I install Qt 5.9.1 to /opt directory and reinstall net-tools and libnlopt0 using sudo apt-get --reinstall install net-tools libnlopt0 command.
In terminal I used "export LD_LIBRARY_PATH=/opt/Qt/5.9.1/gcc_64/lib:$LD_LIBRARY_PATH", and this removes Qt error messages.
For Qt installation, I used "qt-unified-linux-x64-3.1.1-online.run" installer.

I don't get error messages from Qt, but orbmodule is probably problem:
"salome_meca/V2019_univ/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError("Process %d for %s not found" % (thePID,theName))
RuntimeError: Process 5245 for /Kernel/Session not found"

Can somebody help in this matter.

BR
Ilkka

#12 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-02 17:32:27

Hello,

Ubuntu 18.04 worked after giving command: sudo apt-get install libQt5* net-tools libnlopt0.

I have attached print screen, it says 2018 but You read 2019 ?

Ubuntu 16.04 is under investigation, have not get solution or it.

BR
Ilkka

#13 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-01 14:40:40

Hello

mathieu.courtois wrote:

Hello all!

For the error message at startup "/Kernel/Session" not found, it should be solved by installing these packages:

net-tools
libnlopt0

I reinstall these packages, but didn't solve the problem at least in my environment.

BR Ilkka

#14 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-01 12:45:58

Hello,

this below didn't solve the problem.


mecour wrote:

Hello,

there is classical problem with libstdc++.
I can solve it by deleting link libstdc++.so.6 in

HOME/salome_meca/V2019_univ/prerequisites/debianForSalome/lib

and create new link to system libraries.
ln -s /usr/local/lib64/libstdc++.so.6

then the salome-meca starts well.

but if I want to run AsterStudy module I get many errors from PyQT library like:
AttributeError: module 'PyQt5.Qt' has no attribute 'Qt'

The python problem is only with AsterStudy module, all other modules works fine.
mecour


Naturally there can be this libstdc++ problem, but looking that something other problem also.



Br Ilkka

#15 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-10-01 06:24:24

I download Salome V 9.3 binary from salome-platform.org site and it was possible to start up. I seems, that there is something, when making transition from salome v 9.3 to salome-meca 2019, but what?

BR Ilkka

#16 Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2019-09-27 07:45:09

IV_CoAs
Replies: 41

Hello,

I tried to launch salome-meca 2019 in Ubuntu 16.04  platform. I get following errors. Before this stage there was some libQt errors, but using
"export LD_LIBRAY_PATH=" ponting to salome-meca lib/Qt-591 folder solve it. This error below is too complicate for me. I hope, that somebody can help in tihs matter.

BR Ilkka


runSalome running on palvelin-lnx
Searching for a free port for naming service: 2820 - OK
Searching Naming Service  + found in 0.1 seconds
Searching /Kernel/Session in Naming Service  ++Traceback (most recent call last):
  File "/home/laskentamylly/salome_meca/V2019_univ/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 172, in waitNSPID
    os.kill(thePID,0)
ProcessLookupError: [Errno 3] No such process

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/laskentamylly/salome_meca/appli_V2019_univ/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/laskentamylly/salome_meca/appli_V2019_univ/bin/salome/runSalome.py", line 578, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/laskentamylly/salome_meca/V2019_univ/modules/KERNEL_V9_3_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError("Process %d for %s not found" % (thePID,theName))
RuntimeError: Process 10248 for /Kernel/Session not found


--- Error during Salome launch ---

#17 Salome-Meca usage » MEDReader Array names » 2019-05-29 08:30:52

IV_CoAs
Replies: 0

Hello,

I have in MED result file from CA multiple arrays, example below:
['TS0/VERKKO/ComSup0/LASKU___CONT_NOEU@@][@@P1']
['TS0/VERKKO/ComSup1/LASKU___DEPL@@][@@P1']
['TS0/VERKKO/ComSup2/TULOS___EPEQ_NOEU@@][@@P1', 'TS0/VERKKO/ComSup2/TULOS___SIEQ_NOEU@@][@@P1', 'TS0/VERKKO/ComSup2/TULOS___SIGM_NOEU@@][@@P1']

Problem is, that how with using python code I can print these names. Example, if I have following code:
resu=MedReader(FileName='/home/user/result/result.rmed')
print resu.AllArrays,

Result from  print resu.AllArrays is: ['TS0/VERKKO/ComSup0/LASKU___CONT_NOEU@@][@@P1']

Question is, how I can print them all not only  ['TS0/VERKKO/ComSup0/LASKU___CONT_NOEU@@][@@P1'] .

Best Regards
Ilkka

#18 Code_Aster usage » Contact problem with methode penalisation » 2018-08-01 06:56:42

IV_CoAs
Replies: 0

Hello

For some reason, when using contact method penalisation and plastic materials (VMIS_ISOT_LINE, ECRO_LINE) and trying to find out limit load, I have get integration problems and when program made shorter time step (DEFI_LIST_INST), it cannot find solution. I have get same results with different models; it is not question of this particular model. I get impression, that program takes wrong initial values in these cases; not from last converged solution, but something else. I didn't have this problem with version 12.7 (tested with same model)

I have attached mess file, line 3301 is the beginning of "problems". I  am thinking, that while making revisions to DEFI_CONTACT, some bug is left in the code. Naturally I am not specialist, but I hope that somebody is and can check this matter.

Best Regards
Ilkka

#20 Re: Code_Aster installation » [SOLVED] Code-Aster 13.6 and base files glob.1 files » 2018-07-27 08:53:29

Hello,

I used as_run from terminal, --stderr and --stdout options. I have attached files; I changed absolute paths to $HOME variable.

I hope this can help to find reason as the files provides more information.


BR
Ilkka

#21 Re: Code_Aster installation » [SOLVED] Code-Aster 13.6 and base files glob.1 files » 2018-07-26 09:21:01

Hello,

I started to compile from 13.6.0 and then 13.5.14 etc, and I found version 13.5.8 is OK, but 13.5.9 is not (hg pull && hg update 13.6.0, hg pull && hg update 13.5.14, hg pull && hg update 13.5.13,...). It seems, that at least in my system there is some change between these two versions which creates this problem. Maybe some signal is changed or missing.

BR
Ilkka

#22 Re: Code_Aster installation » [SOLVED] Code-Aster 13.6 and base files glob.1 files » 2018-07-24 06:51:31

Hello,

Unfortunately difference between 13.4 and 13.6 is only in xterm window short time and I don't know how to redirect it to file.

Difference is, that part, where files glob.1 and pick.1 are copied to place, which is given in ASTK, 13.4 make copying, but 13.6 doesn't make copying of glob.1 and pick.1

BR
Ilkka

#23 Code_Aster installation » [SOLVED] Code-Aster 13.6 and base files glob.1 files » 2018-07-21 10:32:18

IV_CoAs
Replies: 7

Hello,

I  have compiled and installed Code-Aster 13.6 using 13.4 components (med, mumps, etc). Installation directory (Aster root) is same for 13.4 and 13.6 version. Version 13.6 work fine except it doesn't write base files (glob.1 and pick.1) after analysis or clear interrupt. Version 13.4 makes these files.

I hope, that somebody can help or give hint in this matter.

BR
Ilkka

#24 Re: Code_Aster installation » [SOLVED] Code Aster 13.6 » 2018-07-18 15:47:53

Thank You tianyikillua, for motivation.

Using bitbucket (I made clone using hg) and env_stable.sh enviroment, Rev. 13.6 was able compile using Rev. 13.4 MUMPS, MED 3.2.1,... components.

Below part of first run log file:

                                                                               
              -- CODE_ASTER -- VERSION : EXPLOITATION (stable) --               
                                                                               
                     Version 13.6.0 modifiée le 09/07/2018                     
                     révision 28076ff5fb81 - branche 'v13'                     
MPI_Init...


BR
IV_CoAs

#25 Code_Aster installation » [SOLVED] Code Aster 13.6 » 2018-07-18 06:41:06

IV_CoAs
Replies: 4

Hello,

Can somebody provide estimation, when Code Aster 13.6-full-src package will be in Download page (now only 13.4-ful-src). It would be good, because it is in new Salome-Meca 2018 (if I understand documentation right).


BR
IV_CoAs