
Code_Aster Version
default

Titre : FORMA02 - Travaux pratiques de la formation « Init[...] Date : 02/12/2017 Page : 1/17
Responsable : BEIGNION Céline Clé : V7.15.100 Révision  :

26d9a4431ed9

FORMA02 - Travaux pratiques de la formation 
« Initiation » : tuyau coudé sous sollicitation 
thermo-mécanique et dynamique 

Résumé :

Ce test correspond aux travaux pratiques de la formation de base à l’utilisation de Code_Aster. Il s’agit d’une
tuyauterie  coudée,  constituée  d’un  matériau  élastique  linéaire,  soumise  à  divers  chargements :  pression
interne, transitoire thermique, force transitoire.

Les modélisations utilisées sont les suivantes :
• modélisation A : modélisation 3D, calcul thermo-mécanique,
• modélisation B : modélisation 3D, calcul dynamique, modal puis transitoire,
• modélisation C : éléments coques DKT, calcul mécanique sous chargement de pression interne,
• modélisation D : éléments poutres (POU_D_T), calcul dynamique.

Le chapitre 1 « Problème de référence » présente le problème à traiter et les données communes à toutes les
modélisations ; les énoncés des Travaux Pratiques de la formation sont inclus dans ce document :

• TP2 : « 3D  thermo-élastique» voir la modélisation A,
• TP2 : « 3D dynamique » voir la modélisation B.
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1 Problème de référence
1.1 Géométrie

L’étude concerne une tuyauterie comprenant deux tuyaux droits et un coude [Figure 1.1-a].
Les données géométriques du problème sont les suivantes :

• la longueur LG  des deux tuyaux droits est de 3m ,

• le rayon Rc  du coude est de 0.6 m ,

• l’angle   du coude est de 90 ° ,
• l’épaisseur e  des tuyaux droits et du coude est de 0.02 m ,
• et le rayon extérieur Re  des tuyaux droits et du coude est de 0.2m .
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Figure 1.1-a

Remarque : 
La géométrie du problème présente une symétrie par rapport au plan A , X ,Y  . 

1.2 Propriétés de matériaux 
Pour toutes les modélisations :
Matériau élastique linéaire isotrope. les propriétés du matériau sont celles de l’acier A42  à 20 ° C  :

• le module d’Young E=204 000.10+6 N /m2 , 

• le coefficient de Poisson =0.3 .

Pour le calcul thermo-élastique (modélisation A) :
• le coefficient de dilatation thermique =10.92 10– 6

/°C ,

• la conduction thermique =54.6W /m°C ,

• la chaleur volumique Cp=3.71106 J /m3°C ,
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Pour le calcul dynamique (modélisations B, D) :
• la masse volumique =7800kg /m3 ,

• l’amortissement des modes propres sera pris à 5%  pour les modes.

1.3 Conditions aux limites et chargements
Les conditions aux limites pour toutes les modélisations sont les suivantes : 
• il y a un encastrement au niveau de la section A ,
• pour les chargements statiques, il y a encastrement au niveau de la section A  et de la section

B .

En ce qui concerne les calculs statiques, les chargements appliqués sont de trois types :
• pression interne P=15.10+6 N /m2  (modélisation coques ou 3D),
• chargement thermo-mécanique avec un transitoire de température imposée sur la face interne de

la tuyauterie (montée de 20 °C  à 70 °C  en 10s ) et une condition d’échange nul sur la face
externe de la tuyauterie (calorifuge) (modélisation A uniquement).

En  ce  qui  concerne  le  calcul  dynamique,  le  chargement  appliqué  est  une  force  transitoire  (en
Newton) :
FY ( t)=10000 000.sin (2π Freq1 . t)  dirigée selon l’axe Y  et appliquée sur la section B ,

Freq1  telle que =2 Freq1=121 rad / s . 
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2 Solution de référence 
2.1 Méthode de calcul utilisée pour la solution de référence 

La solution de référence est  obtenue numériquement,  il  s’agit  donc uniquement  des tests de non
régression.

2.2 Résultats des différentes modélisations :
2.2.1 Calcul statique 

Les valeurs testées sont :
• pour le  chargement de pression (modélisations A et C), le  déplacement en sortie supérieure

de coude, 
• pour le chargement thermo-mécanique (modélisation A), la température en paroi interne au

pied du tube (70°C) ainsi que la contrainte Von Mises maximale de l’ordre de 200 MPa. 

2.2.2 Calcul dynamique

Les valeurs testées sont :
• Pour la modélisation 3D (modélisation B), la première fréquence propre de l’ordre de 9 Hz et

les déplacements en sortie supérieure de coude,
• pour la modélisation 1D (modélisation D), les contraintes équivalentes en pied de tube.
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3 Modélisation A 
3.1 Caractéristiques de la modélisation

Glossaire : dans Salomé on désigne par :
• vertex les points utiles à la construction de la géométrie ;
• edge les lignes (droites) ;
• arc les arcs de cercles ;
• wire les lignes composées de edge et arc ;
• face les surfaces délimitées par un wire ;
• shell un ensemble de face destiné à être maillé ou délimitant un volume ;
• compound un ensemble d’entités géométriques.

Les  tuyaux  droits  et  le  coude  sont  modélisés  par  des  éléments  massifs  isoparamétriques
quadratiques. 
La tuyauterie présente un plan de symétrie Z=0 . On ne maille qu’un demi volume.
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3.2 Géométrie
Lancer le module Geometry de la plate-forme Salome-Meca.

Deux procédés pour créer la géométrie : 
• Extrusion d’une surface de base selon un chemin : 

1. Création des points Ae1 , Ai1 , Ae2 , Ai2 , Pe1 , Pi1 , puis des arcs de cercle L1
et L2 , des segments d1  et d2  (Menu New Entity → Basic → …).

2. Création du contour (wire) et de la surface (objet de type " Face ") délimitée par L1 ,

d1 , l2 , d2  (Menu New Entity → Build → …).
3. Création du chemin filaire : les points A ,C , D ,B , puis les deux droites AC  et DB ,

et l’arc de cercle CD .
4. Cette  surface  est  ensuite  extrudée  par  le  menu New Entity  →  Generation  →

Extrusion Along Path.

• Utilisation d’objets volumiques de base :
1. Construire un tuyau droit d’axe Z , à l’aide de deux cylindres élémentaires de hauteur 3

et de rayons  0.2  et  0.18  (Menu  New Entity  → Primitives  → Cylinder),  et
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d’une opération booléenne (Menu Operations → Boolean → Cut). Renommer l’objet
créé en TUY1 .

2. Appliquer  une  rotation  à  TUY1  autour  de  X  pour  qu’il  soit  d’axe  Y  (Menu
Operations → Transformation → Rotation). 

3. Sélectionner la face supérieure (en créant par exemple un groupe – Menu New Entity
→ Group  → Create Group),  et  générer  le  coude  par  le  menu  New Entity  →
Generation → Revolution. Il faut pour cela créer l’axe de révolution de direction Z
passant par le point (0.6, 3 ,0) .

4. Puis créer de la même façon le second tuyau droit TUY2 .
5. Il reste à sélectionner la moitié de la tuyauterie située dans le plan Z0 . Pour cela on

peut couper à l’aide d’un outil "Box" (Menu New Entity → Primitives → Box), ou de
la partition (Menu Operations → Partition) après avoir créé un plan (Menu New
Entity → Basic → Plane), et créer un "compound" en sélectionnant la partie située
en Z>0  (Menu New Entity → Build → Compound).

Préparation de la géométrie pour un maillage en hexaèdres   :
Le tuyau est  destiné à être  maillé  avec  des hexaèdres,  c’est  à dire  de façon réglée (le  nombre
d’éléments est identique sur deux côté opposés). Avant de procéder au maillage, il est nécessaire de
vérifier que la géométrie est topologiquement équivalente à un hexaèdre (6 faces). Pour cela, il faut
utiliser le menu Inspection → Check Compound of Blocks.

Selon le mode de construction,  il  peut être nécessaire de réaliser une partition par des plans des
sections entrée et sortie de coude afin  d’obtenir  une géométrie  topologiquement  équivalente à un
hexaèdre  (6  faces).  Si  on  veut  faire  un  maillage  avec  des tétraèdres,  cette  condition  n’est  pas
nécessaire. En revanche, si on veut mailler en hexaèdre, c’est indispensable pour les algorithmes des
mailleurs.

Création des groupes :
On créera ensuite les groupes de faces où on désire mettre des conditions limites : Base, Symetrie,
Efond, Surfint et Surfext (Menu New Entity → Group → Create Group).
On créera aussi le groupe de bord avec une arête de l’épaisseur ( d1  ) et un autre groupe de bord
avec une arête de circonférence ( L1 )pour permettre un raffinement différent sur ces bords.

On  pourra  tester  l’autre  mode  d’utilisation  de  module  Geometry /Mesh,  consistant  à  produire,
éventuellement modifier, et relire un fichier python, qui contient toutes les instructions nécessaires à la
construction de la géométrie. On crée ce fichier par le menu File → Dump Study. Ce fichier python
peut  être  relu  par  le  menu  File  →  Load Script.  Ceci  permet  en  particulier  de modifier  les
dimensions  de  la  géométrie.  À  titre  d’exemple,  on  pourra  examiner  le  contenu  du  fichier
forma02a.datg, et le relire dans Salome-Meca.

3.3 Maillage
Lancer le module Mesh de la plate-forme Salome-Meca.

Le maillage est défini par le menu Mesh → Create Mesh. Sélectionner la géométrie à mailler, puis
l’algorithme et l'hypothèse de discrétisation par dimension : 

• 3D Hexa h edron (i,j,k). 
• 2D Quadrangle.
• 1D Wire Discretisation avec l’hypothèse de 15 segments par edge.

Pour permettre un raffinement différent selon les edges, on créera des sous-maillages par le menu
Mesh → Create Sub-mesh :

• Un sub-mesh définissant le nombre de segments dans l’épaisseur, par exemple 2 segments
sur  d1  et  l’hypothèse  supplémentaire « Propagation  of  1D  hypothese  on
Opposite Edges ».
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• Un  sub-mesh définissant  le  nombre  de  segments  sur  la  circonférence,  par  exemple  10
segments sur L1 et l’hypothèse supplémentaire « Propagation of 1D hypothese on
Opposite Edges ».

Puis calculer le maillage (Menu Mesh → Compute).
Créer l es groupes d e maill es correspondants aux groupe géométriques  ( Menu Mesh → Create
Groups f rom Geometry ) . 
E xport er le maillage au format MED . 

Remarques : 
Avec une autre finesse de maillage, il est possible d’obtenir des résultats sensiblement différents. En
particulier, pour obtenir une solution correcte, il est souhaitable d’utiliser des éléments quadratiques.

3.4 Création et lancement du cas de calcul (via AsterStudy)
Lancer le module AsterStudy de la plate-forme Salome-Meca . 
Puis en colonne gauche, cliquer sur l'onglet Case View. 

On définit le fichier de commandes du cas de calcul. 

Nota : ajouter des commandes par le menu Commands → Show All. 

L’étude nécessite un premier calcul thermique transitoire suivi d’un calcul mécanique.

Les principales étapes pour la création et le lancement du cas de calcul sont les suivantes : 
• Lire le maillage au format MED : Commande  LIRE_MAILLAGE. 
• Définir le matériau : Commande  DEFI_MATERIAU . 

Calcul thermique     : 
• Définir les éléments finis utilisés : Commande  AFFE_MODELE pour la modélisation en 3D. 
• Affecter le matériau : Commande  AFFE_MATERIAU. 
• Affecter les  conditions  aux  limites  thermiques et  le  chargement :  Commande 

AFFE_CHAR_THER_F : 
- On a un transitoire de température imposée sur la surface intérieure de la tuyauterie

(montée de 20 ° C  à 70° C  en 10s  avec la commande DEFI_FONCTION). 
- On considère que la tuyauterie est calorifugée et on ne spécifie pas de condition sur

la surface extérieure (ce qui revient à un flux nul).
• Résoudre le problème thermique  linéaire :  Commande THER_LINEAIRE,  en définissant un

état initial de température uniforme égal à 20 ° C  (Initial condition (ETAT_INIT)).
Le calcul  du champ de température s’effectue pour les instants  0,5 et10s  définis  par la
commande DEFI_LIST_REEL. 

Calcul thermo-mécanique     : 
• Définir les éléments finis utilisés : Commande  AFFE_MODELE pour la modélisation en 3D. 
• Affecter  le  matériau :  Commande  AFFE_MATERIAU. Le résultat  du calcul  thermique sera

appliqué  en  tant  que  variable  commandant  le  comportement  du  matériau  mécanique
(external state variable assignement (AFFE_VARC)).

• Affecter les  conditions  aux  limites  mécaniques  et  le  chargement :  Commande 
AFFE_CHAR_MECA  :

- L a  tuyauterie  est  encastrée  à  ses deux  extrémités  et  elle  présente  un  plan  de
symétrie : Enforce DOF (DDL_IMPO) . 

- On a une pression en surface interne de 15 MPa   : PRES_REP . 
• Résoudre le problème mécanique statique linéaire  : Commande  MECA_STATIQUE avec le

calcul du champ de température défini ci-dessus. 
• Calculer le champ  : Commande  CALC_CHAMP. 

- pour  le  c alcul  du champ de contraintes par  éléments extrapolées aux  nœuds  :
CONTRAINTE / SIEF_ELNO . 
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-  pour le c alcul du champ de contraintes équivalentes de Von Mises  :  CRITERES /
SIEQ_ELNO . 

• Imprimer les valeurs maximales du tenseur de contraintes  SIEQ_ELNO au format  Result
(RESULTAT) et imprimer le champs de température, les déplacements, et les champs de
contraintes au format MED : Commande  IMPR_RESU. 

• Pour lancer le cas de calcul, en colonne gauche, cliquer sur l'onglet History View.

3.5 P ost-traitement des résultats 
3.5.1 Avec Salomé 

Lancer le module ParaViS de la plate-forme Salome-Meca . 

• Ouvrir le fichier de résultats ( Menu File → Open Para V iew File ) contenant la partie
« mécanique ». Appliquer le filtre Merge Blocks par le m enu Filters . 

• Ouvrir le  fichier  de  résultats contenant  la  partie  « thermique ». Appliquer  le  filtre  Merge
Blocks . 

• Sélectionner des deux objets Merge Blocks puis appliquer le filtre Apprend Attributes .
• Visualiser le maillage déformé ( Menu Filters → Common → Warp By Vector ) avec l a

température et l es contraintes aux points de Gauss ( Menu Filters → ELGA field To
Surface ). 

3.5.2 Avec l’explorateur de résultats Stanley

A l’aide de cet explorateur, on pourra tracer :
• la déformée, en sélectionnant le champ DEPL,
• les isovaleurs des contraintes de Von Mises aux nœuds,
• l’évolution de la température en fonction du temps aux points Pi1  et Pe1 .

3.5.3 Avec Aster_Study en ajoutant un stage

Les principales étapes de la seconde exécution avec Aster_Study seront : 
• Extraire les valeurs la composante SIYY du champ SIEF_ELNO pour un azimut au niveau de

l’entrée  de  coude  pour  le  cas  de  charge  correspondant  à  Fy  :  Commande
MACR_LIGN_COUPE.  L’azimut  est  défini  par  le  chemin  d’extrémités  0.18 ,3,0.  et

0.2 ,3, . 0. .
• Imprimer la table produite au format XMGRACE : Commande  IMPR_TABLE. 
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4 Modélisation B 
Glossaire : dans Salomé on désigne par :

• vertex les points utiles à la construction de la géométrie ;
• edge les lignes (droites) ;
• arc les arcs de cercles ;
• wire les lignes composées de edge et arc ;
• face les surfaces délimitées par un wire ;
• shell un ensemble de face destiné à être maillé ou délimitant un volume ;
• compound un ensemble d’entités géométriques.

Les  tuyaux  droits  et  le  coude  sont  modélisés  par  des  éléments  massifs  isoparamétriques
quadratiques. 
La tuyauterie  présente un plan de symétrie  Z=0 .  Mais  contrairement,  au cas statique,  on n’en
profitera pas. On verra en effet, que les modes peuvent sortir du plan de symétrie. On maillera donc
tout le volume.

X

Z
X

Y

Z

d1 

L1 

 

4.1 Géométrie :
Lancer le module Geometry de la plate-forme Salome-Meca.

Deux procédés pour créer la géométrie : 
• Extrusion d’une surface de base selon un chemin : 

1. Création des cercles intérieurs et extérieurs de la base ( Menu New Entity → Bas ic
→ Circle) ,  puis la surface délimitée par les deux cercles ( Menu  New Entity →
Build → Face ). 

2. Création du chemin filaire :  les points  A ,  C ,  D ,  B ,  puis les deux droites  AC  et
DB , et l’arc de cercle CD  (Menu New Entity → Basic → …), puis le contour (Menu
New Entity → Build → Wire).

3. Cette  surface  est  ensuite  extrudée  par  le  menu  New Entity  →  Generation  →
Extrusion Along Path.

• Utilisation d’objets volumiques de base :
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1. Construire un tuyau droit d’axe Z , à l’aide de deux cylindres élémentaires de hauteur 3
et de rayons  0.2  et  0.18  (Menu  New Entity → Primitives → Cylinder),  et
d’une opération booléenne (Menu Operations → Boolean → Cut). Renommer l’objet
créé en TUY1 .

2. Appliquer  une  rotation  à  TUY1  autour  de  X  pour  qu’il  soit  d’axe  Y  (Menu
Operations → Transformation → Rotation). 

3. Sélectionner la face supérieure (en créant par exemple un groupe – Menu New Entity
→ Group  → Create Group),  et  générer  le  coude  par  le  menu  New Entity  →
Generation → Revolution. Il faut pour cela créer l’axe de révolution de direction Z
passant par le point 0.6 ,3 ,0 .

4. Puis créer de la même façon le second tuyau droit TUY2 .

Préparation de la géométrie pour un maillage en hexaèdres  : 
Pour un maillage en hexaèdres, il faut utiliser l’algorithme « Hexahedron(i,j,k) » ou bien utiliser l’option
« Automatic Hexahedralization ».

Le tuyau est  destiné à être  maillé  avec  des hexaèdres,  c’est  à dire  de façon réglée (le  nombre
d’éléments est identique sur deux côté opposés). Avant de procéder au maillage, il est nécessaire de
vérifier que la géométrie est topologiquement équivalente à un hexaèdre (6 faces). Pour cela, il faut
utiliser le menu Inspection → Check Compound of Blocks.

Selon le mode de construction,  il  peut être nécessaire de réaliser une partition par des plans des
sections entrée et sortie de coude afin  d’obtenir  une géométrie  topologiquement  équivalente à un
hexaèdre  (6  faces).  Si  on  veut  faire  un  maillage  avec  des tétraèdres,  cette  condition  n’est  pas
nécessaire. En revanche, si on veut mailler en hexaèdre, c’est indispensable pour les algorithmes des
mailleurs.

 

Création des groupes :
On créera ensuite les groupes de faces où on désire mettre des conditions limites : Base ainsi que la
section B au bout du tuyau pour appliquer la force dynamique (Menu  New Entity → Group →
Create Group).
On créera aussi le groupe de bord avec une arête de l’épaisseur ( d1  ) et un autre groupe de bord
avec une arête de circonférence ( L1 )pour permettre un raffinement différent sur ces bords.
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Pour  le  post-traitement  il  est  pratique  de créer  un groupe sur  un point  où l’on puisse suivre  les
évolutions. On créera donc le groupe point B  situé sur la section B , en bas, sur la surface intérieure
du tuyau.
 

4.2 Maillage
Lancer le module Mesh de la plate-forme Salome-Meca.

Le maillage est défini par le menu Mesh → Create Mesh. Sélectionner la géométrie à mailler, puis
l’algorithme et l'hypothèse de discrétisation par dimension : 

• 3D Hexa h edron (i,j,k). 
• 2D Quadrangle.
• 1D Wire Discretisation avec l’hypothèse de 15 segments par edge.

Pour permettre un raffinement différent selon les edges, on créera des sous-maillages par le menu
Mesh → Create Sub-mesh :

• Un sub-mesh définissant le nombre de segments dans l’épaisseur, par exemple 2 segments
sur  d 1  et  l’hypothèse  supplémentaire « Propagation  of  1D  hypothese  on
Opposite Edges ».

• Un  sub-mesh définissant  le  nombre  de  segments  sur  la  circonférence,  par  exemple  10
segments sur L1 et l’hypothèse supplémentaire « Propagation of 1D hypothese on
Opposite Edges ».

Puis calculer le maillage (Menu Mesh → Compute).
Créer l es groupes d e maill es correspondants aux groupe géométriques  ( Menu Mesh → Create
Groups f rom Geometry ) . 
E xport er le maillage au format MED . 

Pour obtenir une meilleure précision, on va faire passer le maillage de linéaire à quadratique, grâce à
l’outil « Modification -> Convert to/from quadratic ». Les plus curieux peuvent comparer
les différences de résultats entre les deux types d’éléments.

Remarques : 
Avec une autre finesse de maillage, il est  possible d’obtenir des résultats sensiblement
différents. En particulier, pour obtenir une solution correcte, il est souhaitable d’utiliser des
éléments quadratiques.
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4.3 Création et lancement du cas de calcul
Les principales étapes du calcul avec Code_Aster seront :

• Préparation des données et analyse modale
On va utiliser le « wizard » pour l’analyse modale. Il suffit d’entrer les données de calcul en suivant les
fenêtres affichées. Il ne faut pas oublier de spécifier l’encastrement sur la base. On calculera les cinq
premiers modes du tuyau.

On lancera ensuite le calcul dans le module SALOME Code_Aster. On pourra visualiser les modes
dans SALOME en les « déformant ». On peut aussi les « animer » grâce à la fonction  Sweep. Elle
permet de mieux comprendre la déformée modale.
Dans PARAVIS, cette animation se fait  directement via la macro  modes.On sélectionne le mode à
visualiser ensuite dans l’objet ScaleVector de l’arbre.

 
• Analyse transitoire
Pour l’analyse transitoire, on partira du fichier de commande créé par le « wizard » de SALOME. On y
ajoutera les commandes nécessaires à la suite de l’analyse.

Construction de la force ponctuelle 
• Définition de la charge « force sur la section B  » (AFFE_CHAR_MECA / FORCE_FACE).
• Calcul des vecteurs forces élémentaires (CALC_VECT_ELEM).
• Assemblage du vecteur force (ASSE_VECTEUR).
• Définition de la fonction évolution du temps (FORMULE).

Transitoire sur base modale
• Projection du problème assemblé sur la base des modes propres (PROJ_BASE).
• Calcul  transitoire  par  recombinaison  modale  (DYNA_VIBRA(TYPE_CALCUL=’TRAN’,

BASE_CALCUL=’GENE’).
• Récupération des déplacements en Y  au point B  (RECU_FONCTION).
• Impression de ces fonctions au format TABLEAU (IMPR_FONCTION).
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4.4 P ost-traitement des résultats 
On importera dans SALOME le tableau des déplacements en fonction du temps et on fera construire à
SALOME la courbe des déplacements au point B .
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5 Modélisation C 
Dans le cas de la modélisation en éléments coques, le maillage consiste en la discrétisation de la
surface moyenne de la tuyauterie. La géométrie étant symétrique par rapport au plan A , X ,Y  , on
ne maille qu’une demi-surface. 

  

5.1 Géométrie
On peut créer cette géométrie en définissant les points A1 , P  et A2 , puis l’arc de cercle Base
(Menu New Entity → Basic → …).
Il suffit ensuite de créer le premier tuyau droit  AC  par le menu New Entity → Generation →
Extrusion.
Pour créer le coude, il faut récupérer l’extrémité du tuyau AC  en appliquant le menu New Entity →
Explode,  puis  générer  la  géométrie  du  coude  par  le  menu  New Entity  →  Generation  →
Revolution.
Enfin, appliquer la même démarche pour le tuyau DB  et créer un "compound" en sélectionnant la
partie situPRES=PRES,),
ée en Z0  (Menu New Entity → Build → Compound).

On  créera  ensuite  les  groupes  de  faces  où  on  désire  mettre  des  conditions  limites :  Base,
Symetrie, Efond et surface du tuyau (Menu New Entity → Group → Create Group).
On créera aussi le groupe point A1 .

5.2 Maillage
Lancer le module Mesh de la plate-forme Salome-Meca.

Le maillage est défini par le menu Mesh → Create Mesh. Sélectionner la géométrie à mailler, puis
l’algorithme et l'hypothèse de discrétisation par dimension : 

• 2D Quadrangle . 
• 1D Wire Discretisation avec l’hypothèse de 15 segments par edge.

Pour permettre un raffinement différent selon les edges, on créera un sous-maillage (Menu Mesh →
Create Sub-mesh )  définissant  le  nombre  de  segments  sur  la  circonférence,  par  exemple  10
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segments  sur  base  et  l’hypothèse  supplémentaire « Propagation of 1D hypothese on
Opposite Edges ».

Puis calculer le maillage (Menu Mesh → Compute).
Créer l es groupes d e maill es correspondants aux groupe géométriques  ( Menu Mesh → Create
Groups f rom Geometry ) . 
E xport er le maillage au format MED . 

5.3 Création et lancement du cas de calcul (via AsterStudy ) 
Lancer le module AsterStudy de la plate-forme Salome-Meca . 
Puis en colonne gauche, cliquer sur l'onglet Case View. 

On définit le fichier de commandes du cas de calcul. 

Nota : ajouter des commandes par le menu Commands → Show All. 

L’étude nécessite un premier calcul thermique transitoire suivi d’un calcul mécanique.

Les principales étapes pour la création et le lancement du cas de calcul sont les suivantes : 
• Lire le maillage au format MED : Commande  LIRE_MAILLAGE. 
• Définir les éléments finis utilisés : Commande  AFFE_MODELE. Les tuyaux droits et le coude

seront modélisés par des éléments de coque (DKT).
• Orienter des normales aux éléments : Commande  MODI_MAILLAGE / ORIE_NORM_COQUE

pour orienter tous les éléments de la même façon, avec une normale tournée vers l’intérieur
du tuyau (étant  donné la  convention de signe sur la  pression) afin  de donner une valeur
positive à la pression (utiliser le groupe A1 ).

• Définir  le  matériau :  Commande  DEFI_MATERIAU . Les caractéristiques mécaniques sont
identiques sur toute la structure.

• Affecter le matériau : Commande  AFFE_MATERIAU. 
• Affecter les  caractéristiques des  éléments  coques :  Commande  AFFE_CARA_ELEM  /

COQUE pour définir l’épaisseur.
• Affecter les  conditions  aux  limites  mécaniques  et  les  chargements :  Commande 

AFFE_CHAR_MECA :
◦ Il  y a un encastrement  sur le groupe de mailles  Base  et Efond  des conditions de

symétrie (déplacement normal DZ  nul et rotations DRX  et DRY  nulles) sur le groupe
de mailles Symetrie  : Enforce DOF (DDL_IMPO).

◦ Une pression interne P  : PRES_REP.
• Résoudre le problème élastique : Commande  MECA_STATIQUE.
• Imprimer les déplacements et les contraintes au format  MED : Commande  IMPR_RESU. On

imprimera sous forme listing le déplacement pour chaque résultat sur la section B.
• Pour lance r le cas de calcul, en colonne gauche, cliquer sur l'onglet History View . 
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6 Modélisation D 
6.1 Géométrie

On peut créer la géométrie en définissant les points A ,C , D , B , puis les deux droites AC  et DB ,
et l’arc de cercle CD . Ceci peut se faire de plusieurs façons :
• En définissant les coordonnées de chaque point, y compris le point milieu de l’arc  CD  (Menu

New Entity → Basic → …);
• De  façon  plus  simple  en  utilisant  l'outil  « Sketcher »  (Menu  New Entity  →  Basic → 2D

Sketch ).

Après avoir construit l’ensemble de la ligne, il faut définir les groupes sous ce « Wire » : il suffira pour
ces travaux pratiques de créer les groupes  A ,  B ,  AC ,  CD , et  DB  (  Menu  New Entity →
Group → Create Group ).

6.2 Maillage
Lancer le module Mesh de la plate-forme Salome-Meca.

Le maillage est défini par le menu Mesh → Create Mesh. Sélectionner la géométrie à mailler, puis
l’algorithme  et  l'hypothèse  de  discrétisation  par  dimension :  1D Wire Discretisation  avec
l’hypothèse de 15 segments par edge.

6.3 Création et lancement du cas de calcul (via AsterStudy)
Lancer le module AsterStudy de la plate-forme Salome-Meca . 
Puis en colonne gauche, cliquer sur l'onglet Case View. 

On définit le fichier de commandes du cas de calcul. 

Nota : ajouter des commandes par le menu Commands → Show All. 

L’étude nécessite un premier calcul thermique transitoire suivi d’un calcul mécanique.

Les principales étapes pour la création et le lancement du cas de calcul sont les suivantes : 
• Lire le maillage au format MED : Commande  LIRE_MAILLAGE. 
• Définir les éléments finis utilisés : Commande  AFFE_MODELE.
• Définir le matériau : Commande  DEFI_MATERIAU . 
• Affecter le matériau : Commande  AFFE_MATERIAU . 
• Affecter les caractéristiques des éléments poutres : Commande  AFFE_CARA_ELEM . 
• Affecter  les  conditions  aux  limites  mécaniques  et  le  chargement  :  Commande 

AFFE_CHAR_MECA / Enforce DOF (DDL_IMPO). Le point A  est encastré.
• Définir les matrices du problème  élastique  :  Commande ASSEMBLAGE / MASS_MECA  et

RIGI_MECA.
• Calculer les 5 premiers modes propres : Commande CALC_MODES.
• Imprimer  les modes propres au format  MED :  Commande  IMPR_RESU. On  imprimera  le

maillage et les modes.

Pour lancer le cas de calcul, en colonne gauche, cliquer sur l'onglet History View.

Analyse transitoire     :

• Construction de la force ponctuelle 
1. Affecter  la  charge  « force  au  point  B  »  :  Commande  AFFE_CHAR_MECA /

FORCE_NODALE.
2. Calculer les vecteurs forces élémentaires : Commande CALC_VECT_ELEM.
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3. Construire  un  champ  aux  nœuds  par  assemblage  du  vecteur  force  :
Commande ASSE_VECTEUR.

4. Définir la fonction évolution du temps : Commande FORMULE.

• Transitoire sur base modale
1. Projection  du  problème  assemblé  sur  la  base  des  modes  propres  :  Commande

PROJ_BASE.
2. Calculer le transitoire par recombinaison modale : Commande DYNA_VIBRA.
3. Extraire les déplacements en Y  en B  : Commande RECU_FONCTION.
4. Imprimer ces fonctions au format TABLEAU : Commande IMPR_FONCTION.
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