enfr

FAQ - Installation

Question : Quels sont les pré-requis à l’installation de Code_Aster ?

Réponse : La langage de commande du Code_Aster s’appuie sur Python, et les outils permettant de lancer une étude, une surcharge avec des développements propres, etc., sont écrits en Tcl.

Il est donc nécessaire d’installer Python et Tcl avant d’installer Code_Aster. Consultez la page de téléchargement des logiciels libres.

Question : Quelle version du compilateur doit-on utiliser pour développer dans le Code_Aster ?

Réponse : D’une manière générale, il est conseillé d’utiliser la dernière version des compilateurs C, C++ et Fortran.

GCC (pour GNU Compiler Collection qui intègre le compilateur C, C++ et Fortran) est utilisé sous Linux.

Sous les Unix propriétaires, il est préférable d’utiliser le compilateur du constructeur, il doit être possible d’utiliser gcc, mais cela n’a pas encore été testé.

Sous Windows, les compilateurs utilisés sont ceux du Visual Studio.

Question : Je n’arrive pas à installer un pré-requis. Que faire ?

Réponse : La première chose est de consulter les fichiers README ou INSTALL fournis dans la distribution.

Si ceux-ci ne suffisent pas, consultez le site web du produit concerné, il y a probablement des FAQ ou un forum pour poser vos questions.

Question : L’installation de Code_Aster s’est mal déroulée, où trouver de l’aide ?

Réponse : Lisez attentivement le fichier README ou INSTALL inclus dans la distribution.

Avez-vous installé tous les pré-requis ? Demandez de l’aide dans le forum Installation avec un minimum de matière (message d’erreur…).